Bug 250797 - ppc64 debuginfo has stripped strace64.debug
Summary: ppc64 debuginfo has stripped strace64.debug
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: strace   
(Show other bugs)
Version: 5.0
Hardware: ppc64
OS: Linux
urgent
low
Target Milestone: ---
: ---
Assignee: Jan Kratochvil
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: Regression
Depends On: 250794
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-03 17:41 UTC by Jan Kratochvil
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0826
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:35:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0826 normal SHIPPED_LIVE strace bug fix update 2007-11-08 14:13:58 UTC

Description Jan Kratochvil 2007-08-03 17:41:03 UTC
+++ This bug was initially created as a clone of Bug #250794 +++

The same problem would affect RHEL-5.1; it could or could not have the luck.

Description of problem:
During the RHEL4.5->RHEL4.6 build the verification (rpmdiff) failed as the
generated strace64.debug is empty.

Version-Release number of selected component (if applicable):
strace-4.5.16-1.el4.ppc64

How reproducible:
Not tried.

Steps to Reproduce:
1. Build strace-4.5.16-1.el4.ppc64 in Brew.

Actual results:
-rwxr-xr-x  1 jkratoch jkratoch 301600 Aug  3 18:43
strace-debuginfo-4.5.16-1.el4.ppc64/usr/lib/debug/usr/bin/strace.debug*
-rwxr-xr-x  1 jkratoch jkratoch   2640 Aug  3 18:43
strace-debuginfo-4.5.16-1.el4.ppc64/usr/lib/debug/usr/bin/strace64.debug*

(strace.debug correct, strace64.debug stripped)

Expected results:
-rwxr-xr-x  1 jkratoch jkratoch   2640 Aug  3 18:55
strace-debuginfo-4.5.15-1.el4.1.ppc64/usr/lib/debug/usr/bin/strace.debug*
-rwxr-xr-x  1 jkratoch jkratoch 294216 Aug  3 18:55
strace-debuginfo-4.5.15-1.el4.1.ppc64/usr/lib/debug/usr/bin/strace64.debug*

(strace.debug stripped, strace64.debug unstripped)

Well, it is also broken but it does not hurt.
The correct way is to produce both the two .debug files unstripped.
ppc64 platform uses strace.ppc and strace64.ppc64.
The package strace.ppc64 is never used.

Additional info:
The problem is line:
ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
/usr/lib/rpm/find-debuginfo.sh randomly chooses the first file and the second
one is already stripped so even its .debug file is empty/stripped.
Suggesting `ln' -> `cp -p'.

Comment 1 Andrew Cagney 2007-08-03 17:48:45 UTC
Regression on RHEL-4.5.
Problem is in debuginfo; so has no significant customer impact.
Workaround is trivial.
Tested automatically as part of errata process.


Comment 2 RHEL Product and Program Management 2007-08-03 17:55:49 UTC
Since Keyword Regression exists, this is a blocker,
not an exception.  Cleared exception flag.
Set blocker flag."

Comment 4 Andrew Cagney 2007-08-03 19:55:50 UTC
Where did my dev_ack go?
> Regression on RHEL-4.5.
> Problem is in debuginfo; so has no significant customer impact.
> Workaround is trivial.
> Tested automatically as part of errata process.
> 



Comment 8 Jan Kratochvil 2007-08-08 13:45:40 UTC
Problem fixed in Rawhide rpm-build by the new Roland's find-debuginfo.sh,
reported for RHEL in the Bug 251333.


Comment 11 errata-xmlrpc 2007-11-07 16:35:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0826.html



Note You need to log in before you can comment on or make changes to this bug.