Bug 250905 - libmtp version bump to libmtp.so.6
libmtp version bump to libmtp.so.6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-04 18:21 EDT by Linus Walleij
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-05 13:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Walleij 2007-08-04 18:21:11 EDT
I've updated libmtp in devel but it seems that it has not
propagated yet. It bumps the soname from libmtp.so.5 to
libmtp.so.6 so probably needs Amarok to be rebuilt at some
point. Maintainers of other distros claims it needs no
patching.
Comment 1 Linus Walleij 2007-08-05 12:29:48 EDT
The new interface is now available in devel, please rebuild
amarok ASAP.
Comment 2 Aurelien Bompard 2007-08-05 13:23:57 EDT
I've just rebuilt it, thanks.
Comment 3 Todd Zullinger 2007-08-05 17:32:16 EDT
Linus, is a libmtp update planned for F7?  If so, perhaps we can coordinate any
amarok rebuild there with the a possible update of libgpod (which isn't yet a
definite for F7).  Since amarok is a reasonably large update, it would be nice
for users not to have to download it twice within a week just for library
updates (and nice to Aurelien so he doesn't need to rebuild more often than
needed :).  If you could CC me on any F7 libmtp update planning, that'd be
excellent.

See bug #250781 for planning and status on a libgpod update for devel now, and
possibly for F7 after some testing in rawhide.  It's just waiting to hear back
from the maintainers of the affected packages to give a go (I'm willing to push
any rebuilds via chain build to avoid broken deps hitting the repos).
Comment 4 Linus Walleij 2007-08-05 18:41:15 EDT
If we are to push libmtp 0.2.0 for F7 amarok alongside libgpod 
we can do that, dragging in gnomad2 to the mix but nothing else 
hopefully.

I will update then libmtp to 0.2.0 and tag it but not build it.

When you are set to update libgpod you also start build of libmtp,
so the subsequent build of amarok will pick up both. Then you
also trig a rebuild of gnomad2 (you can simply bump that in CVS
and tag+build it yourselves unless you want me to do that also).

OK? If this is a plan I'll go ahead and move libmtp 0.2.0 to the
F7 CVS and tag it as soon as you tell me.
Comment 5 Todd Zullinger 2007-08-06 23:38:42 EDT
There are several packages depending on libgpod which would need rebuilt
(amarok, gtkpod, kipi-plugins, and rhythmbox).  So it's a little bit of
wrangling.  I'm quite willing to kick off a chain-build to ensure that all of
the packages hit the repos together and no one gets any broken deps nag mail
(hopefully).

It's not a definite that it'll get updated in F7 either.  I'm in favor of it (so
I can update gtkpod), but it's not entirely my call.  It depends on what the
maintainers of the other libgpod using packages want to do.

So, since libgpod hasn't been pushed to rawhide as of yet, it will be a week or
so until it could hit F7.  I don't know how often is too often to rebuild and
push a package like Amarok.  Aurelien, what do you think?

I also don't know how eager you are to get the updated libmtp into F7.  If
waiting a few days or so to see how the maintainers that depend on libgpod feel
about an F7 update is okay for you guys, that'd be great.  (I know that
Rhythmbox maintainer (and main libgpod maintainer) Bastien Nocera is on
holidays, so he's not going to be as available as he normally would be.)  If
waiting and coordinating it all is more pain than it's worth, that's probably
fine too. :)
Comment 6 Aurelien Bompard 2007-08-14 05:45:58 EDT
I'll be updating Amarok this Thursday, but I don't think we can update libmtp
before Thursday morning UTC. I don't own an mtp device so I'm not particularly
eager to have an updated libmtp, bug I don't mind rebuilding Amarok as much as
necessary. The mirrors won't sync more than once a day anyway ;)
Comment 7 Linus Walleij 2007-08-14 16:46:15 EDT
Will the libgpod stuff be fixed by thursday or is there something else
causing the rebuild?
Comment 8 Aurelien Bompard 2007-08-15 07:04:56 EDT
It's something else. It's a secret release I'm not supposed to tell you about... ;)
Comment 9 Todd Zullinger 2007-08-15 15:00:12 EDT
Sorry for the delay.  The libgpod update hasn't gone anywhere yet.  Some of the
other maintainers have been away (probably enjoying the summer weather :).  I
don't want to hold things up so if you want to push the libmtp update to F7,
might as well go for it.

Aurelien, I see you rebuilt amarok for F7, but AFAICT, libmtp hasn't been pdated
there yet.  It's still libmtp.so.5 in the koji build here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=13802

(And it looks like the berkeley db update has caused a missing dep for ruby in
the F8 build.  Fun fun.)
Comment 10 Linus Walleij 2007-08-18 16:36:39 EDT
I didn't make any update of libmtp this was a bit too quick. But I'll
sure follow on the libgpod rebuild train if possible.

Note You need to log in before you can comment on or make changes to this bug.