Bug 250966 - Missing libgoffice4 dependency
Missing libgoffice4 dependency
Status: CLOSED DUPLICATE of bug 242163
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-06 03:40 EDT by Mark Wielaard
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 17:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (18.96 KB, text/plain)
2007-08-07 15:33 EDT, Mark Wielaard
no flags Details

  None (edit)
Description Mark Wielaard 2007-08-06 03:40:13 EDT
Description of problem:

Upgrade to Fedora 7 and trying to run gnucash fails.

Version-Release number of selected component (if applicable):

gnucash-2.2.0-1.fc7

How reproducible:

Always
Steps to Reproduce:
1. Upgrade to Fedora 7
2. Type gnash in a terminal window

  
Actual results:

gnucash-bin: error while loading shared libraries: libgoffice-0.so.4: cannot
open shared object file: No such file or directory

Expected results:

gnash starting up

Additional info:

/usr/lib/libgoffice-1.so.2 is installed. libgoffice-0.so.4 is available after a
yum install libgoffice4. Afterwards gnucash starts up.
Comment 1 Bill Nottingham 2007-08-06 14:05:50 EDT
$ rpm -qpR gnucash-2.2.0-1.fc7.i386.rpm | grep goffice
libgoffice-0.so.4  

The requires is there.
Comment 2 Mark Wielaard 2007-08-06 15:06:38 EDT
If the bug isn't in the gnucash package, then where could it be?
I have seen the same issue with 2 systems that were upgraded to Fedora 7 and had
gnucash already installed.
Comment 3 Bill Nottingham 2007-08-06 15:27:35 EDT
Not sure. pushing to anaconda for now.
Comment 4 Chris Lumens 2007-08-07 15:17:34 EDT
Please attach /var/log/anaconda.log to this bug report.
Comment 5 Mark Wielaard 2007-08-07 15:33:57 EDT
Created attachment 160847 [details]
Anaconda log
Comment 6 Mark Wielaard 2007-08-07 15:36:36 EDT
Attached the anaconda log
Comment 7 Hans de Goede 2007-08-17 03:21:36 EDT
This feels like a dupe of bug 242163, same problem / symptoms but just with a
different lib.
Comment 8 Mark Wielaard 2007-08-17 05:53:25 EDT
(In reply to comment #7)
> This feels like a dupe of bug 242163, same problem / symptoms but just with a
> different lib.

Aha. On one of the machines after the upgrade the install also has problems with
gnumeric as described in that bug report:

$ gnumeric
gnumeric: error while loading shared libraries: libgsf-gnome-1.so.114: cannot
open shared object file: No such file or directory

Since gnumeric isn't used on that machine, but was apparently installed from a
previous Fedora release, I haven't fixed that issue yet, so if there is anything
I can provide to track this down please let me know.
Comment 9 David Cantrell 2007-09-11 17:16:59 EDT

*** This bug has been marked as a duplicate of 242163 ***

Note You need to log in before you can comment on or make changes to this bug.