Bug 242163 - gnumeric-1.6.3-6.fc7 missing dependency
gnumeric-1.6.3-6.fc7 missing dependency
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
:
: 250966 253148 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 17:40 EDT by Frank Cox
Modified: 2008-06-16 21:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:21:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log (49.92 KB, text/plain)
2007-06-04 14:12 EDT, Frank Cox
no flags Details

  None (edit)
Description Frank Cox 2007-06-01 17:40:37 EDT
Description of problem:
There appears to be a missing dependency on gnumeric-1.6.3-6.fc7
.

After updating from FC6 to Fedora 7, gnumeric no longer works, with  "error
while loading shared libraries: libgsf-gnome-1.so.114: cannot open shared
object file: No such file or directory"

"yum install libgsf-gnome" solves the problem.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.Install gnumeric on FC6
2.Upgrade to F7
3.Run gnumeric
  
Actual results:
"error while loading shared libraries: libgsf-gnome-1.so.114: cannot open shared
object file: No such file or directory"

Expected results:
gnumeric running without error

Additional info:
can be solved with "yum install libgsf-gnome"
Comment 1 Hans de Goede 2007-06-03 14:32:00 EDT
Actually, gnumeric requires libgsf-gnome-1.so.114, and thus libgsf-gnome:
[hans@shalem devel]$ rpm -q --requires gnumeric|grep gsf
libgsf-1.so.114
libgsf-gnome-1.so.114
[hans@shalem devel]$ rpm -q --whatprovides libgsf-gnome-1.so.114
libgsf-gnome-1.14.3-4.fc7

So it look like the update process somehow didn't drag in libgsf-gnome, while it
should have, reassignen to anaconda-maint-list@redhat.com and changing component
to anaconda.
Comment 2 Chris Lumens 2007-06-04 10:26:10 EDT
Please attach /root/upgrade.log to this bug report.
Comment 3 Frank Cox 2007-06-04 14:12:37 EDT
Created attachment 156103 [details]
upgrade.log
Comment 4 Jeremy Katz 2007-06-04 14:24:23 EDT
Did you run a 'yum update' after going through the anaconda upgrade?
Comment 5 Frank Cox 2007-06-04 14:44:51 EDT
I'm not sure that I understand the question.

I updated my system from FC6 to F7 using a boot cd with the DVD image on my
fileserver, then I ran "yum update" immediately after doing that.

Later that same day I discovered that Gnumeric didn't work any more without the
additional libgsf-gnome package which I installed and then all was once again well.

Does that provide the answer that you need?
Comment 6 Hans de Goede 2007-08-17 03:23:11 EDT
*** Bug 253148 has been marked as a duplicate of this bug. ***
Comment 7 David Cantrell 2007-09-11 17:16:59 EDT
*** Bug 250966 has been marked as a duplicate of this bug. ***
Comment 8 Wes Garrett 2008-04-15 13:20:26 EDT
I think a problem I'm having is related to this one.  I reinstalled Fedora 7 on
my laptop on Monday, ran software updater, and now when I go into gnumeric,
click insert, click function, click all functions (long list), I see only three
functions:  gnumeric_version, product, and sum.

Before installing on my laptop, I reinstalled Fedora 7 on my PC on Saturday, and
ran software updater, but unlike my laptop, I see far more functions than just
three.

Did some dependency changes for gnumeric go in over the weekend?
Comment 9 Bug Zapper 2008-05-14 08:43:29 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2008-06-16 21:21:29 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.