This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 251069 - fatal xorg server error - caught signal 11
fatal xorg server error - caught signal 11
Status: CLOSED DUPLICATE of bug 251051
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-06 17:20 EDT by Clyde E. Kunkel
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 04:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2007-08-06 17:20:45 EDT
Description of problem: booted rawhide this AM and did a yum update, rebooted
and server failed with backtrace.


Version-Release number of selected component (if applicable): current rawhide
version of server


How reproducible:  allways


Steps to Reproduce:
1. boot rawhide
2. auto start of x fails, rhgb fails, goes into terminal mode.
3. manually trying startx fails same way.
  
Actual results:
Backtrace:
0: X(xf86SigHandler+0x81) [0x80cf2d1]
1: [0x12c420]
2: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONSetSyncRangeFromEdid+0x1d)
[0x50fe3d]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0x50102c]
4: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONPreInit+0xb89) [0x504599]
5: X(InitOutput+0x9a8) [0x80a3698]
6: X(main+0x27b) [0x80715bb]
7: /lib/libc.so.6(__libc_start_main+0xe0) [0x247110]
8: X(FontFileCompleteXLFD+0x1fd) [0x8070ac1]

Fatal server error:
Caught signal 11.  Server aborting



Expected results:
Normal startup


Additional info:

Rebooted into FC7, same machine, X starts normally as does rhgb.

I also noticed in the rawhide xorg log the following which seems to be different
from what I remember:

(WW) No FontPath specified.  Using compiled-in default.
(==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x820df80

Here is what I see in FC7 xorg log irunning xorg-x11-xinit-1.0.2-19.fc7

(WW) No FontPath specified.  Using compiled-in default.
(==) FontPath set to:
    unix/:7100,
    built-ins
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x820d960
Comment 1 Michael Schwendt 2007-08-07 04:36:56 EDT

*** This bug has been marked as a duplicate of 251051 ***

Note You need to log in before you can comment on or make changes to this bug.