Bug 251051 - X crashes after updating ATI driver to version 6.6.193
X crashes after updating ATI driver to version 6.6.193
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 251069 251100 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-08-06 14:47 EDT by Joachim Frieben
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 03:59:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log for ATI driver 6.6.193 (23.34 KB, text/plain)
2007-08-06 14:47 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2007-08-06 14:47:37 EDT
Description of problem:
After updating the ATI driver package to version 6.6.193, X doesn't
start any more. The Xorg.0.log file exhibits a backtrace related to
the crash.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.193-1.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Update ATI driver package.
2. Restart X.
  
Actual results:
X fails to start up.

Expected results:
X starts up correctly.

Additional info:
Downgrading to version 6.6.3 restores normal operation. Backtrace info
for version 6.6.193 included in attached Xorg.0.log.
Comment 1 Joachim Frieben 2007-08-06 14:47:37 EDT
Created attachment 160763 [details]
Xorg.0.log for ATI driver 6.6.193
Comment 2 Michael Schwendt 2007-08-07 04:37:03 EDT
*** Bug 251069 has been marked as a duplicate of this bug. ***
Comment 3 Michael Schwendt 2007-08-07 04:37:57 EDT
*** Bug 251100 has been marked as a duplicate of this bug. ***
Comment 4 Dave Airlie 2007-08-07 18:27:19 EDT
Can you test 

http://people.fedoraproject.org/~airlied/rawhide/xorg-x11-drv-ati-6.6.193-2.fc8.src.rpm

I think one of our Fedora patches might be causing this..
Comment 5 Michael Schwendt 2007-08-07 18:46:29 EDT
> 6.6.193-2.fc8

works for me
Comment 6 Dave Airlie 2007-08-07 21:06:38 EDT
okay I've pushed the specfile change to remove the patch, I'll try and rework it
later for 6.6.193..

Comment 7 Joachim Frieben 2007-08-08 03:59:08 EDT
Fixed in "xorg-x11-drv-ati-6.6.193-2.fc8".

Note You need to log in before you can comment on or make changes to this bug.