This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 251174 - Liberation fonts are not equivalent to core fonts when used in OpenOffice
Liberation fonts are not equivalent to core fonts when used in OpenOffice
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 304441
  Show dependency treegraph
 
Reported: 2007-08-07 12:08 EDT by Joe Smith
Modified: 2008-01-14 00:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 22:42:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 77698 None None None Never

  None (edit)
Description Joe Smith 2007-08-07 12:08:42 EDT
Description of problem:
Using the Liberation fonts to replace MS core fonts in an OpenOffice text
document leads to changes in layout--the fonts appear to have non-equivalent
metrics. The same replacement using AbiWord shows perfect metric equivalence.

Version-Release number of selected component (if applicable):
The LiberationMono-Bold.ttf file is marked as version 1.0

How reproducible:
always--depends on font display settings (hinting), see comments at OO.org

Additional info:
Originally reported to OO.org:
http://www.openoffice.org/issues/show_bug.cgi?id=77698

Since the comments there suggest that there may be some issue with the font
metrics and/or Freetype, it seemed reasonable to ask you folks take a look as well.
Comment 1 Caius Chance 2007-08-16 22:20:18 EDT
Checking with upstream.
Comment 3 Caolan McNamara 2007-10-02 05:52:09 EDT
Have we got any obvious test cases with various pages of text in e.g. msoffice
under windows in the microsoft fonts and then the same text in the liberation
fonts to verify that we get the same no of lines per page and characters per
line with msoffice, just a smoke-test sanity testcase ?
Comment 4 Jens Petersen 2007-10-08 19:49:04 EDT
I don't know of any, but it would certainly be a good thing to have.

Joe, do you have some document you can attach here which demonstrates
the problem?
Comment 5 Joe Smith 2007-10-09 21:41:03 EDT
I attached a simple test document to the OO.org issue linked above.

I also repeated some tests with that document, and reported what I found there
as well.

Bottom line: only OO.org builds (on F7) are showing any difference, and only for
Times New Roman vs. Lib Serif (roman, italic and bold faces; bold+italic is ok).

Also, the difference comes from TNR being rendered narrower; the Lib Serif
samples are rendered with the same widths in both OO.org and Fedora builds as
well as in AbiWord.

So, all the samples have the same width using the Fedora OOo build, and for the
OO.org build, it looks like the Liberation fonts are not the source of the problem.

Thanks for having a look--I think this can probably be closed.
Comment 6 Caius Chance 2007-10-09 22:00:39 EDT
Hi jensp, would it be viable to use Fedora OOo build by default? Or it had been
using already?
Comment 7 Caius Chance 2007-10-09 22:42:54 EDT
> OO.org build, it looks like the Liberation fonts are not the source of the
problem.
> Thanks for having a look--I think this can probably be closed.

Welcome. Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.