Bug 251266 - livecd needs goodies, i.e. html, other stuff on the iso9660 root, like ubuntu
livecd needs goodies, i.e. html, other stuff on the iso9660 root, like ubuntu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
: 219557 (view as bug list)
Depends On:
Blocks: FC6LiveCDTracker F8Blocker
  Show dependency treegraph
 
Reported: 2007-08-07 19:38 EDT by Jane Dogalt
Modified: 2013-01-09 23:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 12:43:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jane Dogalt 2007-08-07 19:38:03 EDT
Description of problem:

The f7/8t1 livecd's iso9660 filesystem is bare.  I.e. only the minimal files
required for the bootloader and the livecd (is the /sysroot empty dir really
necessary?)

Whereas the ubuntu livecd iso has all kinds of goodies.  Such as icon and
autorun for windows cd-insertion scenario.  I.e. automatically spawning a
webbrowser to view the locally included (on the iso9660 root fs) html file. 
They even throw in windows installers for firefox, etc...  They also throw in
windows tools to help create obscure boot disks (i.e. that sbm stuff)

To regain parity with ubuntu, and even surpass, the fedora livecd needs this
kind of stuff.

Personally I'd really like to see an installed windows qemu version, such that
when you plop the f8 livecd in a windows system, you can run a win32 version of
qemu straight from the cd (no install reqd), and then boot the livecd itself.

But that is probably not worth it, as from what I hear the win32 version of qemu
is not that robust.  Mainly this bug is about something simpler like an autorun
launching a 'why the f8 livecd is great, and how to use it, and not fear it'
kind of web page.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2007-08-07 20:06:45 EDT
Yeah, we had talked about this at some point during F7, but it kind of fell off
the radar just due to time.

There are two different parts.  The first is the infrastructure to drop such
bits onto the CD.  You had a start of something for that, I had a few other
ideas.  I'll either resurrect that thread tonight or tomorrow or you can.

The second part is working with some combination of Fedora Marketing, Fedora Art
and Fedora Docs to actually get the content we're going to put there.

Sticking on the blocker list so we don't forget about it this time.
Comment 2 Jeremy Katz 2007-09-13 11:16:10 EDT
*** Bug 219557 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2007-10-01 12:43:07 EDT
README and GPL file are there for test3.  Any more content that shows up is easy
enough to add by specific request.

Note You need to log in before you can comment on or make changes to this bug.