Bug 251292 - [XEN-HVM]HVM PV driver is not in RHEL5.1
[XEN-HVM]HVM PV driver is not in RHEL5.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
: 251293 251294 (view as bug list)
Depends On: 241338 247982 247986
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 03:31 EDT by Zhao Yunfeng
Modified: 2009-12-14 16:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 08:24:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zhao Yunfeng 2007-08-08 03:31:57 EDT
Description of problem:
The performance of qemu ide and nic is bad.
HVM PV driver has a good performance.
But I cannot find  HVM PV driver in RHEL5.1.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. 
2. 
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zhao Yunfeng 2007-08-08 03:39:20 EDT
*** Bug 251294 has been marked as a duplicate of this bug. ***
Comment 2 Zhao Yunfeng 2007-08-08 03:40:31 EDT
*** Bug 251293 has been marked as a duplicate of this bug. ***
Comment 3 Gerd Hoffmann 2007-08-09 09:07:16 EDT
Depends on bug 247982 and bug 241338, both targeted for rhel‑5.2.0 according to
flags, which makes this a 5.2 candidate too.
Comment 4 Zhao Yunfeng 2007-08-21 08:54:58 EDT
To fix bug 247982 and bug 241338, only very few changes needed.
I tried to use PV driver(VBD) to boot root file system of a linux os 
successfully with following steps:
1. Build VBD modules into the initrd of the guest kernel.
2. Disable IDE of the HVM guest by adding "ide0=noprobe" in the guest kernel.
3. Modify xen python code to enable a disk image could be defined twice in the 
same config file,as
disk = 
[ 'file:/share/xvs/var/img.vmx17001,hda,w', 'file:/share/xvs/var/img.vmx17001,x
vda,w' ] 
4. then boot the guest.
Comment 5 Gerd Hoffmann 2007-08-21 13:11:27 EDT
Re comment #4:

Have the same disk twice in the system, once emulated and once paravirtualized,
isn't an option.

Beside that it doesn't cover bug 241338.
Comment 6 Zhao Yunfeng 2007-08-21 21:22:11 EDT
(In reply to comment #5)
> Re comment #4:
> 
> Have the same disk twice in the system, once emulated and once paravirtualized,
> isn't an option.
After booted up, the HVM guest will only use VBD driver.
IDE emulation is only a transition to load kernel, just like ide bios driver to
get disk work before os kernel booted up.

We prefer this solution because it only needs a very small change.

Does bug 241338 have any relations with PV driver?

> 

Comment 7 Gerd Hoffmann 2007-08-22 03:52:26 EDT
Re comment #6:

It is very error prone.  If the system is booted without ide0=noprobe for some
reason (and it can happen easily as this has to be configured manually) you have
the disk twice in the guest.  I want make sure this can't happen.

Bug 241338 is related because you need some way to disable the statically
compiled ide drivers if you want pv drivers handle the boot disk.
Comment 8 Zhao Yunfeng 2007-08-22 23:33:17 EDT
We can let initrd of HVM guest disable ide. So user needn't do this manually.


Comment 9 Gerd Hoffmann 2007-08-23 03:28:42 EDT
Re #8:  Suggestions how to do this?  Note that RHEL-5 has the ide drivers
compiled statically into the kernel.

Side note:  In Fedora 7 and newer (ide handled by modular libata) it is easy,
but that doesn't help for RHEL-5 ...
Comment 10 RHEL Product and Program Management 2007-10-15 23:50:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Chris Lalancette 2008-02-26 22:19:57 EST
Now that we have released the kmod-xenpv packages with the PV-on-HVM drivers,
can we close this bug out?

Thanks,
Chris Lalancette
Comment 12 RHEL Product and Program Management 2008-03-11 15:43:24 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 13 Bill Burns 2009-01-21 08:24:50 EST
Closing. No response to the need info request and the PV drivers are now part of the RHEl 5 distribution with RHEL 5.3.

Note You need to log in before you can comment on or make changes to this bug.