Bug 251300 - Serial port (one onboard - "com2") not detected with kernels >= 2.6.22
Serial port (one onboard - "com2") not detected with kernels >= 2.6.22
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 253406 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 04:32 EDT by Miroslav Pragl
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 17:59:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Pragl 2007-08-08 04:32:27 EDT
After upgrade to 2.6.22 (happens in any kernel since this one) FC7 doesn't 
detect serial port. There's only one serial port ("com2" settings) in my 
notebook. I't's used by built-in infraport as ordinary serial 115.200 dongle so 
if ttyS1 is not available irda doesn't work either.

Old (working) kernels' message:
Jul 13 13:44:31 localhost kernel: Serial: 8250/16550 driver $Revision: 1.90 $ 4 
ports, IRQ sharing enabled
Jul 13 13:44:31 localhost kernel: serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 
16550A

Now:
Jul 22 21:05:39 localhost kernel: Serial: 8250/16550 driver $Revision: 1.90 $ 4 
ports, IRQ sharing enabled

might have something to do (?) with:
Jul 22 16:51:15 localhost kernel: cs: IO port probe 0x100-0x3af: excluding 
0x2f8-0x2ff 0x378-0x37f

and the only non-default HW related setting in my system is:
/etc/pcmcia/config.opts 
exclude irq 3

Tried setserial:
#setserial /dev/ttyS1 port 0x02f8 irq 3 uart 16550A
Cannot set serial info: Invalid argument

Thanks

Miroslav
Comment 1 Radovan Garabík 2007-08-10 06:41:37 EDT
I have similar problems, with Fujitsu-Siemens P1510 notebook, touchscreen is on 
ttyS1 and after the upgrade from 2.6.21.5 to 2.6.22 the kernel fails to detect 
serial ports. Unlike the original reporter, this is Debian unstable and I am 
using vanilla kernels.
Comment 2 Chuck Ebbert 2007-08-10 11:02:32 EDT
Please try the kernel option "legacy_serial.force".
Comment 3 Miroslav Pragl 2007-08-10 11:34:38 EDT
legacy_serial.force=1 did the trick, thanks!

Miroslav
Comment 4 Chuck Ebbert 2007-08-10 17:50:51 EDT
Patch in CVS to fix this.
Comment 5 Chuck Ebbert 2007-08-21 12:24:15 EDT
*** Bug 253406 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.