Bug 251321 - rhgb screen switches between "show details" mode and graphical mode
rhgb screen switches between "show details" mode and graphical mode
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-08 07:51 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-08 11:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-08-08 07:51:03 EDT
I can't *believe* I am reporting this bug, for what must be the sixth time.

Every time I see this bug (which is every box I have ever installed Fedora on),
and every time I report it, I get a flat denial of the problem even existing, or
a complete lack of response.

So I'll give it one last go.

At boot, I get a pretty loading screen which uses X.
There are two problems, the first problem is more annoying.

1. The "Show details" button does not work.

The "Show details" button will occasionally switch back to the pretty X loading
screen. This is phenomenally annoying, for several reasons:
i) it's doing the complete opposite of what I told it to do
ii) I wanted to see all the details, which is why I clicked the "Show details"

The second problem is similar.

2. If the "Show details" button is not clicked, I get flashes between the
"Details" and the pretty X loading screen.

That's about it - if I let the box boot normally, without clicking anything at
all, about 2/3rds of the way through I will get a flash of the "Details" for a
second or so, then back to the pretty X loading screen.
Comment 1 Ray Strode [halfline] 2007-08-08 09:48:41 EDT
Hi, so the first problem I *thought* an outside contributor already fixed.  I'll
have to look.

The second problem is a timing one.  rhgb will automatically go into "Show
Details" mode if the boot process stalls for too long to potentially show the
user why it stalled.  Maybe we should just remove this feature.  What do you think?
Comment 2 Ray Strode [halfline] 2007-08-08 09:51:36 EDT
I found the old bug.  It's bug 151239.

Let's keep that bug for 1.  and keep this bug for discussion about the show
details timeout.
Comment 3 Need Real Name 2007-08-08 10:06:04 EDT
> Maybe we should just remove this feature.

I think as long as the init script is not failing then it should stay in X mode.
If the user wants to see why it is stalled, they can click "Show details".
Comment 4 Mary Ellen Foster 2007-08-08 10:15:58 EDT
I'm the "outside contributor" from the other bug. And I actually got it wrong in
my old patch from the previous bug ... I'll take another look and give it
another try. :)
Comment 5 Ray Strode [halfline] 2007-08-08 10:20:38 EDT
Great, thanks Mary.
Comment 6 Ray Strode [halfline] 2007-08-08 11:43:47 EDT
I've committed (and am building into rawhide now) two untested patches that
should address both issues.

Please reopen if rhgb still has any problems.

Note You need to log in before you can comment on or make changes to this bug.