Bug 251544 - S0 suspend to RAM does not switch off backlight on Thinkpad X32
Summary: S0 suspend to RAM does not switch off backlight on Thinkpad X32
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
(Show other bugs)
Version: 5.1
Hardware: All Linux
high
urgent
Target Milestone: ---
: ---
Assignee: Phil Knirsch
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-09 17:31 UTC by Daniel Riek
Modified: 2015-03-05 01:19 UTC (History)
6 users (show)

Fixed In Version: RHBA-2007-0632
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 18:01:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output of IBM X32 (12.95 KB, application/octet-stream)
2007-09-19 16:21 UTC, Florian La Roche
no flags Details
IBM X32 lspci (5.92 KB, application/octet-stream)
2007-09-19 16:22 UTC, Florian La Roche
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0632 normal SHIPPED_LIVE hal bug fix update 2007-10-30 16:24:05 UTC

Description Daniel Riek 2007-08-09 17:31:21 UTC
With a fresh install of RHEL 5.1 Beta on a Thinkpad X32 with a ATI  Radeon
Mobility M6 LY using the radeon driver suspend to RAM appears to fail to switch
off the backlight. This causes the systom to not fully suspend.

This is a regression from 5.0.

As we did not modify the driver, I am filing this against gnome-power-manager.

Comment 1 RHEL Product and Program Management 2007-08-09 17:35:09 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 2 David Zeuthen 2007-08-09 18:59:55 UTC
You need to provide a working fdi file snippet for this to get fixed; see these
pages for how to do that

 http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html


Comment 3 Florian La Roche 2007-08-15 07:28:09 UTC
Hello Daniel,

do thinks work with "pm-suspend --quirk-old"? That should be the same
as "pm-suspend --quirk-dpms-suspend".

Thanks a lot,

Florian La Roche


Comment 4 Daniel Riek 2007-08-15 18:39:55 UTC
It still works with "--quirk-old" and it also works with "--quirk-dpms-suspend".
The upstreamd quirk from git uses "--quirk-radeon-off" which does NOT work.

Comment 5 David Zeuthen 2007-08-16 22:16:07 UTC
As it works with --quirk-old, there is something wrong with pm-utils as it
should do this automatically when no quirks are passed. Reassigning to pm-utils.

Comment 6 Phil Knirsch 2007-08-17 13:39:39 UTC
Clear Devel ACK as it's a regression.

Fix for pm-utils is available.

Thanks,

Read ya, Phil


Comment 11 Daniel Riek 2007-09-05 22:53:27 UTC
Tried with pm-utils-0.99.3-6.el5.14.i386 but still the same behaviour.

Comment 12 Phil Knirsch 2007-09-06 10:50:20 UTC
After some debugging of the problem i found out that it steems from the newly
added FDI file for IBM laptops in hal:

https://bugzilla.redhat.com/show_bug.cgi?id=251496

If you take a look at the FDI file from comment #26 for IBM laptops there you
seen an entry for the X32 that looks like this:

      <!-- X32 -->
      <match key="system.hardware.version" string="ThinkPad X32">
        <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
      </match>

which contains the radeon_off quirk but not the dpms_suspend quirk. And Daniel
already tested with his IBM X32 that --quirk-dpms-suspend works but
--quirk-radeon-off does not.

So 2 possible solutions are now available:

- Fix the X32 entry like this:

      <!-- X32 -->
      <match key="system.hardware.version" string="ThinkPad X32">
        <merge key="power_management.quirk.dpms_suspend" type="bool">true</merge>
        <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
      </match>

- Remove the whole newly added FDI file.

The reason for the 2nd suggestion comes from an in-depth review of the new IBM
and Lenovo FDI files. It shows that a lot of the quirks for various models
deviate strongly from the original quirks that were used in RHEL-5 GA. As we've
now already found 1 model where the new quirks are not working properly this
seems to be a dangerous change for all IBM and Lenovo laptops despite the tests
that were done using those quirks.

Of course it's up to David to decide which fix to implement, so i'm leaving the
decision up to him.

Reassigning this bug to hal as it needs to be fixed there.

Read ya, Phil

Comment 14 Daniel Riek 2007-09-10 13:52:22 UTC
If I am not completely mistaken, that quirk was not installed on my laptop when
testing. Where should it be?

Addint an FDI with dpms-suspend indeed works (I created my onwn one for daily work).

Here is the fdi-information that is installed:
/usr/share/hal/fdi/information/10freedesktop
/usr/share/hal/fdi/information/10freedesktop/10-camera-ptp.fdi
/usr/share/hal/fdi/information/10freedesktop/10-cd-dvd-burner.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-card-readers.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-pda.fdi
/usr/share/hal/fdi/information/10freedesktop/10-usb-zip-drives.fdi
/usr/share/hal/fdi/information/10freedesktop/10-wireless-mice.fdi
/usr/share/hal/fdi/information/20thirdparty


Comment 15 Daniel Riek 2007-09-10 13:54:28 UTC
Hal version on my test system:
hal-0.5.8.1-23.el5

According to bug 251496 it should not have the IBM FDI.



Comment 16 Phil Knirsch 2007-09-11 12:05:52 UTC
Hello Daniel.

Could you provide the output of

/sbin/lspci -mn

please? Something really strange is going on atm as you should be getting the
old behaviour with the latest version of pm-utils.

Thanks,

Read ya, Phil



Comment 17 Daniel Riek 2007-09-11 16:17:43 UTC
Here ya go:

[root@scorp information]# lspci -nm
00:00.0 "0600" "8086" "3340" -r03 "1014" "0529"
00:01.0 "0604" "8086" "3341" -r03 "" ""
00:1d.0 "0c03" "8086" "24c2" -r01 "1014" "052d"
00:1d.1 "0c03" "8086" "24c4" -r01 "1014" "052d"
00:1d.2 "0c03" "8086" "24c7" -r01 "1014" "052d"
00:1d.7 "0c03" "8086" "24cd" -r01 -p20 "1014" "052e"
00:1e.0 "0604" "8086" "2448" -r81 "" ""
00:1f.0 "0601" "8086" "24cc" -r01 "" ""
00:1f.1 "0101" "8086" "24ca" -r01 -p8a "1014" "052d"
00:1f.3 "0c05" "8086" "24c3" -r01 "1014" "052d"
00:1f.5 "0401" "8086" "24c5" -r01 "1014" "0534"
00:1f.6 "0703" "8086" "24c6" -r01 "1014" "0559"
01:00.0 "0300" "1002" "4c59" "1014" "052f"
02:00.0 "0607" "1180" "0476" -raa "1014" "0532"
02:00.1 "0607" "1180" "0476" -raa "1014" "0532"
02:00.2 "0c00" "1180" "0552" -r02 -p10 "1014" "0533"
02:01.0 "0200" "8086" "101e" -r03 "1014" "0549"
02:02.0 "0280" "8086" "4220" -r05 "8086" "2711"


Comment 18 Phil Knirsch 2007-09-11 16:40:56 UTC
Now i'm really confused.

This should enable the same quirks as RHEL-5 GA and therefore expose the same
behaviour as using pm-suspend --quirk-old or for ATI cards pm-suspend
--quirk-dpms-suspend. I've just verified that this happens on 2 laptops here
with pm-utils-0.99.3-6.el5.12 or newer and a hal package without any
vendor/model specific fdi files (e.g. hal-0.5.8.1-23.el5).

I have 0 clue whats going on here at the moment and can't reproduce it on any
machine here.

The only way i could see whats going on is if i'd get access to that machine.

Read ya, Phil


Comment 27 David Zeuthen 2007-09-21 17:11:03 UTC
Put patch from comment 24 into 0.5.8.1-25.el5

Comment 30 Daniel Riek 2007-09-26 18:59:40 UTC
I tested this and it works.


Comment 32 errata-xmlrpc 2007-11-07 18:01:28 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0632.html



Note You need to log in before you can comment on or make changes to this bug.