Bug 251714 - compiz-0.5.2-1.fc8 doesn't start.....
compiz-0.5.2-1.fc8 doesn't start.....
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 12:19 EDT by Tom London
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 17:15:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of white edges around menus, below top panel (84.45 KB, image/png)
2007-08-14 19:39 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2007-08-10 12:19:06 EDT
Description of problem:
Updating to compiz-0.5.2-1.fc8 'breaks'.... Get no title bars, etc.

Trying to run compiz 'manually' produces:
compiz (core) - Warn: Unable to parse XML metadata from file "core.xml"
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

See nothing in /var/log/messages or /var/log/audit/audit.log.

Reverting to compiz-0.4.0-1.fc8 'fixes'.


Version-Release number of selected component (if applicable):
compiz-0.5.2-1.fc8

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Will Woods 2007-08-10 12:47:50 EDT
Might be a duplicate of bug 251716 - could you try starting compiz like so:

LIBGL_ALWAYS_INDIRECT=1 compiz --replace glib gconf

and note whether that works?
Comment 2 Tom London 2007-08-10 13:35:03 EDT
(In reply to comment #1)
> Might be a duplicate of bug 251716 - could you try starting compiz like so:
> 
> LIBGL_ALWAYS_INDIRECT=1 compiz --replace glib gconf
> 
> and note whether that works?
Running compiz as above seems to prevent it from crashing.

Now, I get the nice 'rotating cube', but no window decorations.
Comment 3 darrell pfeifer 2007-08-10 13:50:54 EDT
I have a similar problem.

Whenever I start compiz 4 I have no window decorations. Turning off desktop
effects and then enabling them right away gives me compiz running correctly
(except I have to redo the window placements).

With 0.5.2-1 I get no window decorations at all. The off/on trick doesn't even
work. Reverting to version 4 fixes the problem. Note that I'm basically unable
to get back to a regular gnome session with window decorations.
Comment 4 Tom London 2007-08-11 13:40:29 EDT
Continue to have compiz/gtk-window-decorator issues with compiz-0.5.2-3.fc8 and
gnome-session-2.19.6-5.fc8.

Enabling compiz via 'desktop-effects' produces windows without decorations.  I
tried all I could figure out to get decorations to no avail.

Running compiz, gtk-window-decorator or both manually does not fix.

Running 'desktop-effects' does not seem to work properly: cannot always revert
back to metacity, so sometimes need to ALT-CTL-BS to get a 'usable' system back.

Should I be able to 'just turn compiz on' by enabling with 'desktop effects'? or
is more needed?
Comment 5 darrell pfeifer 2007-08-11 14:05:19 EDT
Same problem here with compiz-0.5.2-3.fc8 and
gnome-session-2.19.6-5.fc8.

No window decorations via desktop effects. Using desktop effects to turn off
compiz still leaves no window decorations. Worse, reverting to earlier versions
of compiz and gnome-session still leaves non-compiz without desktop effects.
Turing desktop effects on and off repeatedly with the old version eventually
gives a non-compiz session with decorations.
Comment 6 Kristian Høgsberg 2007-08-13 10:50:50 EDT
What kind of error do you get if you try to start compiz like this:

  $ LIBGL_ALWAYS_INDIRECT=1 compiz --replace glib gconf
Comment 7 Jeremy Katz 2007-08-13 11:02:17 EDT
Output is 
  compiz (cube) - Warn: Failed to load slide: freedesktop

And no window decorations.  Have it in my cube if you're in the office and want
to poke at it.
Comment 8 darrell pfeifer 2007-08-13 11:04:03 EDT
>What kind of error do you get if you try to start compiz like this:

>  $ LIBGL_ALWAYS_INDIRECT=1 compiz --replace glib gconf

Using the rawhide versions from today.

There are no window decorations.
No error messages appear at the terminal.
Logging out and back in again still leaves no window decorations (assuming gnome
remembers compiz setting on logout)

It takes several attempts at turning desktop effects off/on afterwards to get
non-compiz back.
Comment 9 Tom London 2007-08-13 11:05:51 EDT
I put the above command in a file along with call to 'gtk-window-decorator'.

Here is what I get:

[tbl@user-64-9-232-168 ~]$ cat compiz*
LIBGL_ALWAYS_INDIRECT=1 compiz --replace glib gconf&
gtk-window-decorator&
[tbl@user-64-9-232-168 ~]$ 
[tbl@user-64-9-232-168 ~]$ sh -x ./compiz.sh
+ LIBGL_ALWAYS_INDIRECT=1
+ compiz --replace glib gconf
+ gtk-window-decorator
[tbl@user-64-9-232-168 ~]$ Gtk-Message: Failed to load module "gnomebreakpad":
libgnomebreakpad.so: cannot open shared object file: No such file or directory

[tbl@user-64-9-232-168 ~]$

Also have no decorations.
Comment 10 Kristian Høgsberg 2007-08-14 15:02:40 EDT
This turns out to be a gconf problem.  Rawhide (compiz-0.5.2-4.0ec3ec.fc8)
should work, but you may have to issue a

  gconftool-2 --unset /apps/compiz/general/allscreens/options/active_plugins

and log out and back in.

Builds:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=102411
Comment 11 Tom London 2007-08-14 18:01:28 EDT
Partial joy!

Followed above instructions (including 'gconf-2').

compiz/gtk-window-decorator now start.  Windows have decorations, and they
wobble too.

However, somethings 'broke':
1. There are 'white areas' immediately below the top panel and above the bottom
panel.
2. Windows (e.g., terminal windows) start up with their title bar and
decorations at least partially 'under the top panel'.
3. Menus from the top panel (e.g., System->Preferences) have a white region on
all sides.
4. The window selector widget that I have on the bottom panel to select 'faces
of the cube' is borked: it rotates to a completely 'blank' panel: only the
fedora background is displayed, no top or bottom panel.  Once this happens,
cannot recover using ALT-CTL-ARROW.  However, ALT-CTL-ARROW keys do NOT produce
this borkage.

Is there some log/info I can provide that will help?
Comment 12 Tom London 2007-08-14 19:39:20 EDT
Created attachment 161316 [details]
Image of white edges around menus, below top panel
Comment 13 Kristian Høgsberg 2007-08-15 10:38:43 EDT
Good news.  I see the white shadows/areas too, it's bug 251953.  The placement
problem is also a gconf related problem, I get that here too.
Comment 14 Tom London 2007-08-15 10:50:39 EDT
Things are a bit better after this morning's Rawhide (not sure why).

The 'white border' around menus and above/below the bottom/top panels are gone.

I removed and reinserted the 'workspace selector' applet, and this now is working.

Remaining quirks:
1. New windows (e.g. terminal windows, firefox) are placed 'below' the top
panel, thus the  decorations are obscured. Moving the window displays the
decorations.

2. 'Saved sessions' aren't working for me.  If I 'startup' compiz via
desktop-effects and then save the current session, then log off and log back in,
I get unexpected (for me) results.  Most often I get a blank workspace (that is,
no 'saved session' apps).  Sometimes I get a blank workspace with neither compiz
nor metacity running.

I notice a gconf setting: /apps/gnome-session/rh/window_manager, currenly set to
'compiz'.  Is that right?
Comment 15 darrell pfeifer 2007-08-15 13:03:03 EDT
Back to working for me too compiz-0.5.2-4.

More quirks:

1) My menu bar is at the top of the screen. New windows are created with their
decorations underneath the menu bar so they can't be moved by grabbing the title
bar. Trying to select an edge/bottom with control/alt only gives resizing, not a
moving handle. The only way to move is to right mouse click on the application bar.

2) I have a similar 'saved sessions' problem. Logging in still gives no window
decorations (did the gconf-2 command). Have to cycle desktop effects off/on to
get them

Good news: The session switcher works for me as alt-ctl-arrow. (It used to
switch within the current session rather than rotating the cube)
Comment 16 Kristian Høgsberg 2007-08-15 17:15:30 EDT
Placement and decoration problems should be fixed in rawhide.  The white borders
were fixed by the Xorg and mesa update in todays rawhide.  You may have to use
the gconftool-2 workaround mentioned above to reset the settings, but the bugs
should be fixed now.  Closing this bug, please open new bugs if the other issues
remain.

Note You need to log in before you can comment on or make changes to this bug.