Bug 251737 - Update the mediacheck procedure
Update the mediacheck procedure
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2007-08-10 15:04 EDT by Till Maas
Modified: 2009-07-17 09:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 09:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2007-08-10 15:04:58 EDT
The Installer Beat (http://fedoraproject.org/wiki/Docs/Beats/Installer)
mentioned two contradicting ways to verify the installation medium, which both
seem to be wrong. In F7 Anaconda just asked whether or not to verify the medium
without to manually edit the kernel commandline. When it is clear how to verify
the F8 installations media, this should be described there, instead of the
current contents.
Comment 1 Till Maas 2007-08-10 15:22:21 EDT
For the Live Images there is a menu entry "Verify and run from image", so I
guess the procedure depends on whether one uses a Live Image or an Install Image.
Comment 2 Karsten Wade 2007-08-10 15:37:38 EDT
Thanks for the report.  I want to make sure we understand a few things:

* Is the actual procedure that made it into the F7 fedora-release-notes package
incorrect?  Here is that page:

http://docs.fedoraproject.org/release-notes/f7/en_US/sn-Installer.html

I guess we also need to check the Installation Guide on this subject, make sure
it is in sync:

http://docs.fedoraproject.org/install-guide/f7/en_US/sn-verifying-media.html

For the current contents in all of Docs/Beats/*, everything definitely needs
updating.  If you have a Wiki account, you could edit these changes you suggest
directly.  I know not everyone can agree to the CLA, but if you are able to,
editing the Wiki for the release notes is a great community effort that extends
beyond the Docs team.
Comment 3 Till Maas 2007-08-10 15:52:24 EDT
(In reply to comment #2)
> Thanks for the report.  I want to make sure we understand a few things:
> 
> * Is the actual procedure that made it into the F7 fedora-release-notes package
> incorrect?  Here is that page:
> 
> http://docs.fedoraproject.org/release-notes/f7/en_US/sn-Installer.html

Yes, this is incorrect:
"linux initrd=initrd.img mediacheck" does not work. Someone changed the "linux"
to "vmlinuz" in the wiki at one place (it was mentioned twice), which does no
harm, because it asks whether or not to verify the disc but this would happen
anyway. I guess it is also not needed to reboot. I do not know, whether or not
the "ide=nodma" is still required. The F7 Live Image has a "Verify and run from
image" entry, too. And this entry does not use "mediacheck" but "check" and some
more kernel commandline options.

 
> I guess we also need to check the Installation Guide on this subject, make sure
> it is in sync:
> 
> http://docs.fedoraproject.org/install-guide/f7/en_US/sn-verifying-media.html

Ah, the install guide is correct (and in contradiction to the release notes).
One minor issue is, that the Live Images are afaik not only CD images but can
also be used with usb sticks, I read that Jesse Keating prefers "Live media"
instead of "Live CD".

> For the current contents in all of Docs/Beats/*, everything definitely needs
> updating.  If you have a Wiki account, you could edit these changes you suggest
> directly.  I know not everyone can agree to the CLA, but if you are able to,
> editing the Wiki for the release notes is a great community effort that extends
> beyond the Docs team.

Yes, I know, but I just found out, what the correct documentation for this is.
And I cannot verify it for F8, yet, because the images do not work in my virtual
machines.
Comment 4 Jason Taylor 2009-01-07 15:39:16 EST
This should be handled in the install guide now, should it not?
Comment 5 eric@christensenplace.us 2009-06-30 11:04:06 EDT
Is this still an issue?
Comment 6 John J. McDonough 2009-07-17 09:32:48 EDT
The section no longer exists.

Note You need to log in before you can comment on or make changes to this bug.