Bug 251769 - Kernel 2.6.22 changed thinkpad module name/location
Kernel 2.6.22 changed thinkpad module name/location
Status: CLOSED DUPLICATE of bug 251015
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-10 19:52 EDT by Sammy
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-13 11:53:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sammy 2007-08-10 19:52:41 EDT
In Fedora 7 2.6.22 based kernel two changes for thinkpad:

1. Module name changed from ibm_acpi to thinkpad_acpi

2. Module location changed from kernel/drivers/acpi/ to 

The immediate result is that rc.sysinit file that loads the
acpi modules from kernel/drivers/acpi/ directory does not
load the thinkpad_acpi module. Also, if people put option
lines into the modprobe.conf for ibm_acpi they will not be
understood, although this is not that important.

Please reassign to initscripts if the location of the module
will stay in the misc directory.
Comment 1 Chuck Ebbert 2007-08-13 11:53:29 EDT

*** This bug has been marked as a duplicate of 251015 ***

Note You need to log in before you can comment on or make changes to this bug.