Bug 25180 - appletproxy crash (knewsticker)
appletproxy crash (knewsticker)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
Florence RC-2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-29 06:16 EST by Tim Waugh
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-11 07:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2001-01-29 06:16:36 EST
I was playing with KNewsTicker.  I had removed dot.kde.org from the list 
of news sources and saved the preferences, and was browsing the menu 
options.

"The application Panel applet proxy. (appletproxy) crashed and caused the 
signal 11 (SIGSEGV)."

(no debugging symbols found)...[New Thread 1024 (LWP 13837)]
0x40ad05e9 in __wait4 () from /lib/libc.so.6
#0  0x40ad05e9 in __wait4 () from /lib/libc.so.6
#1  0x40b3bf08 in __DTOR_END__ () from /lib/libc.so.6
#2  0x402fd5c8 in KCrash::defaultCrashHandler () at eval.c:41
#3  0x40e4d2e1 in pthread_sighandler (signo=11, ctx=

      {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, 
__dsh = 0, edi = 3221220972, esi = 1085515168, ebp = 3221220816, esp = 
3221220636, ebx = 1082471744, edx = 1085515100, ecx = 191, eax = 
1085515094, trapno = 14, err = 6, eip = 1085515144, cs = 35, __csh = 0, 
eflags = 66178, esp_at_signal = 3221220636, ss = 43, __ssh = 0, fpstate = 
0xbfffeaa0, oldmask = 2147483648, cr2 = 1702899331}) at signals.c:97

#4  <signal handler called>
#5  0x40b3a588 in main_arena () from /lib/libc.so.6
#6  0x6840b3a5 in ?? ()
#7  0x404a34b2 in QGDictIterator::QGDictIterator ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#8  0x404a18b7 in QGDict::QGDict () from /usr/lib/qt-2.2.3/lib/libqt.so.2
#9  0x40b3a580 in main_arena () from /lib/libc.so.6
#10 0x000000f9 in __strtol_internal (
    nptr=0x808adb0 "Pb\n\bhD\013\bhh\n\b\021", endptr=0x3e9, 
base=1085515448, 

    group=1085515448) at eval.c:68
#11 0x080af110 in ?? () at eval.c:41
Comment 1 Tim Waugh 2001-01-29 06:18:03 EST
I've added the applet again, and it seems to be working now.
Comment 2 Tim Waugh 2001-01-29 06:21:23 EST
Okay, here's how to reproduce.

rm ~/.kde/share/config/knewstickerrc
Panel->Add applet->News ticker
Right-click, preferences, news sources, remove dot.kde.org, ok
right-click, and hover over each of the news sources in turn until it crashes.
Comment 3 Tim Waugh 2001-01-29 06:28:56 EST
You might have to remove kio_http's cache first too.  Here's another:

(no debugging symbols found)...[New Thread 1024 (LWP 13920)]
0x40ad05e9 in __wait4 () from /lib/libc.so.6
#0  0x40ad05e9 in __wait4 () from /lib/libc.so.6
#1  0x40b3bf08 in __DTOR_END__ () from /lib/libc.so.6
#2  0x402fd5c8 in KCrash::defaultCrashHandler () at eval.c:41
#3  0x40e4d2e1 in pthread_sighandler (signo=11, ctx=

      {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, 
__dsh = 0, edi = 3221221064, esi = 795374637, ebp = 3221220944, esp = 
3221220874, ebx = 1082471764, edx = 3221221096, ecx = 1, eax = 1082391904, 
trapno = 14, err = 4, eip = 1078597759, cs = 35, __csh = 0, eflags = 66066, 
esp_at_signal = 3221220874, ss = 43, __ssh = 0, fpstate = 0xbfffeb88, oldmask 
= 2147483648, cr2 = 795374657}) at signals.c:97

#4  <signal handler called>
#5  0x404a187f in QGDict::QGDict () from /usr/lib/qt-2.2.3/lib/libqt.so.2
#6  0x40f26c63 in KNewsTickerMenu::exec () from /usr/lib/libknewsticker.so.1
#7  0x40f254d3 in KNewsTicker::slotOpenContextMenu ()
   from /usr/lib/libknewsticker.so.1
#8  0x4055a1cb in QObject::activate_signal ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#9  0x40f24282 in NewsScroller::contextMenu ()
   from /usr/lib/libknewsticker.so.1
#10 0x40f20ac4 in NewsScroller::mouseReleaseEvent ()
   from /usr/lib/libknewsticker.so.1
#11 0x405a2e11 in QWidget::event () from /usr/lib/qt-2.2.3/lib/libqt.so.2

#12 0x40503d01 in QApplication::notify () from /usr/lib/qt-2.2.3/lib/libqt.so.2

#13 0x4029a42d in KApplication::notify () at eval.c:41
#14 0x404d399f in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#15 0x404d0e18 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#16 0x404cffca in QApplication::processNextEvent ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#17 0x40505b2c in QApplication::enter_loop ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#18 0x404cff47 in QApplication::exec () from /usr/lib/qt-2.2.3/lib/libqt.so.2
#19 0x4001a314 in main () at eval.c:41
#20 0x40a3bbac in __libc_start_main (main=0x80484fc <main>, argc=6, 
    ubp_av=0xbffffbec, init=0x80484c4 <_init>, fini=0x804867c <_fini>, 
    rtld_fini=0x4000d5e4 <_dl_fini>, stack_end=0xbffffbe4)
    at ../sysdeps/generic/libc-start.c:129

Comment 4 Bernhard Rosenkraenzer 2001-01-29 14:26:47 EST
Can't reproduce this... 
Dropping a note to submit@bugs.kde.org

Comment 5 Bernhard Rosenkraenzer 2001-01-29 15:10:39 EST
Ok, happens here too when using glibc 2.2.1-3, so it seems to be another 
instance of Bug #25029.


*** This bug has been marked as a duplicate of 25029 ***
Comment 6 Tim Waugh 2001-01-30 06:17:20 EST
Not sure: I just reproduced the second of the above traces with 
glibc-2.2-9(i386) installed.  It took longer to do though.

This machine is a 486, in case that's relevant (probably not).
Comment 7 Glen Foster 2001-01-30 15:44:36 EST
This defect is considered MUST-FIX for Florence Release-Candidate #2
Comment 8 Tim Waugh 2001-02-11 07:50:32 EST
Seems I'm the only one who can get this to happen.  I'll take a look.
Comment 9 Tim Waugh 2001-02-24 18:48:38 EST
I can no longer seem to reproduce this.  Guess I'll close this for now, and
reopen it if I ever see it again.

Note You need to log in before you can comment on or make changes to this bug.