Bug 25029 - glibc 2.2.1-3 causes kdm to segfault
glibc 2.2.1-3 causes kdm to segfault
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
Florence RC-1
:
: 26297 26456 27054 28308 28429 28431 29204 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-26 07:35 EST by Tim Waugh
Modified: 2016-11-24 10:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-11 11:23:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdm-log (77.53 KB, text/plain)
2001-01-26 15:39 EST, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2001-01-26 07:35:27 EST
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1024 (LWP 817)]
0x401faa19 in __wait4 () from /lib/libc.so.6
#0  0x401faa19 in __wait4 () from /lib/libc.so.6
#1  0x4026508c in __DTOR_END__ () from /lib/libc.so.6
#2  0x405d55c8 in KCrash::defaultCrashHandler () from
/usr/lib/libkdecore.so.3

#3  <signal handler called>
#4  __errno_location () at errno.c:25
#5  0x40762969 in QFile::open () from /usr/lib/qt-2.2.3/lib/libqt.so.2
#6  0x40569721 in KConfigINIBackEnd::parseConfigFiles ()
   from /usr/lib/libkdecore.so.3
#7  0x4054c43e in KConfigBase::parseConfigFiles ()
   from /usr/lib/libkdecore.so.3

#8  0x40562524 in KSimpleConfig::KSimpleConfig () from
/usr/lib/libkdecore.so.3

#9  0x40575f9d in KApplication::applyGUIStyle () from
/usr/lib/libkdecore.so.3

#10 0x40577e37 in KApplication::kdisplaySetStyle ()
   from /usr/lib/libkdecore.so.3
#11 0x40572bf7 in KApplication::init () from /usr/lib/libkdecore.so.3
#12 0x40572894 in KApplication::KApplication () from
/usr/lib/libkdecore.so.3

#13 0x4027eb39 in GreetUser (d2=0x8061d00, dpy2=0xbffff7f8,
verify2=0x805b620, 

    greet2=0x805b604, dlfuncs=0x805ac00) at kgreeter.cpp:846
#14 0x08052671 in strcpy () at ../sysdeps/generic/strcpy.c:31
#15 0x0804e98b in strcpy () at ../sysdeps/generic/strcpy.c:31
#16 0x0804e6e6 in strcpy () at ../sysdeps/generic/strcpy.c:31
#17 0x0804f138 in strcpy () at ../sysdeps/generic/strcpy.c:31
#18 0x0804e700 in strcpy () at ../sysdeps/generic/strcpy.c:31
#19 0x0804dd6d in strcpy () at ../sysdeps/generic/strcpy.c:31
#20 0x4015ef11 in __libc_start_main (main=0x804dba0 <strcpy+13820>, argc=2, 
    ubp_av=0xbffffd8c, init=0x8049c7c <_init>, fini=0x805659c <_fini>, 
    rtld_fini=0x4000e214 <_dl_fini>, stack_end=0xbffffd84)
    at ../sysdeps/generic/libc-start.c:129
Comment 1 Tim Waugh 2001-01-26 13:36:12 EST
Managed to get some more symbols, if it's helpful.

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1024 (LWP 23223)]
0x401fba19 in __wait4 () from /lib/libc.so.6
#0  0x401fba19 in __wait4 () from /lib/libc.so.6
#1  0x4026608c in __DTOR_END__ () from /lib/libc.so.6
#2  0x405d75c8 in KCrash::defaultCrashHandler (signal=11) at kcrash.cpp:191
#3  <signal handler called>
#4  __errno_location () at errno.c:25
#5  0x407a7ab3 in QFile::open (this=0xbfffe718, m=1)
    at tools/qfile_unix.cpp:252
#6  0x4056b721 in KConfigINIBackEnd::parseConfigFiles (this=0x809d650)
    at kconfigbackend.cpp:181
#7  0x4054e43e in KConfigBase::parseConfigFiles (this=0xbffff018)
    at kconfigbase.cpp:1291
#8  0x40564524 in KSimpleConfig::KSimpleConfig (this=0xbffff018, 
    pFileName=@0x809522c, bReadOnly=false) at ksimpleconfig.cpp:50
#9  0x40577f9d in KApplication::applyGUIStyle (this=0xbffff378)
    at kapp.cpp:1315
#10 0x40579e37 in KApplication::kdisplaySetStyle (this=0xbffff378)
    at kapp.cpp:1586
#11 0x40574bf7 in KApplication::init (this=0xbffff378, GUIenabled=true)
    at kapp.cpp:658
#12 0x40574894 in KApplication::KApplication (this=0xbffff378, 
    allowStyles=true, GUIenabled=true) at kapp.cpp:571

#13 0x4027fb39 in GreetUser (d2=0x8061d00, dpy2=0xbffff538, verify2=0x805b620, 

    greet2=0x805b604, dlfuncs=0x805ac00) at kgreeter.cpp:846
#14 0x08052671 in strcpy () at ../sysdeps/generic/strcpy.c:31
#15 0x0804e98b in strcpy () at ../sysdeps/generic/strcpy.c:31
#16 0x0804e6e6 in strcpy () at ../sysdeps/generic/strcpy.c:31
#17 0x0804f138 in strcpy () at ../sysdeps/generic/strcpy.c:31
#18 0x0804e700 in strcpy () at ../sysdeps/generic/strcpy.c:31
#19 0x0804dd6d in strcpy () at ../sysdeps/generic/strcpy.c:31
#20 0x4015ff11 in __libc_start_main (main=0x804dba0 <strcpy+13820>, argc=1, 
    ubp_av=0xbffffacc, init=0x8049c7c <_init>, fini=0x805659c <_fini>, 
    rtld_fini=0x4000e214 <_dl_fini>, stack_end=0xbffffac4)
    at ../sysdeps/generic/libc-start.c:129
Comment 2 Tim Waugh 2001-01-26 15:38:46 EST
If I do 'touch /root/.kde/share/config/kstylerc', the problem goes away.

I'll attach strace output, obtained by:

# kdm; A=$(($(ps axf | grep [k]dm | head -1 | awk '{ print $1 }') + 12)); sleep
3; strace -fp $A 2>&1 | tee /tmp/kdm-log

(for some reason, 'strace -fp kdm' just gave me a gray stipple screen and
stopped at select()..)
Comment 3 Tim Waugh 2001-01-26 15:39:35 EST
Created attachment 8329 [details]
kdm-log
Comment 4 Bernhard Rosenkraenzer 2001-01-29 15:08:44 EST
This is a glibc problem - install glibc 2.2.1-2 and it'll work perfectly.
Comment 5 Bernhard Rosenkraenzer 2001-01-29 15:10:34 EST
*** Bug 25180 has been marked as a duplicate of this bug. ***
Comment 6 Bernhard Rosenkraenzer 2001-01-29 16:40:53 EST
A workaround is compiling kdebase with --disable-greet-lib, so I guess the 
problem is in dlopen().

Comment 7 Tim Waugh 2001-01-29 18:09:13 EST
With glibc-2.2.1-3.i386 instead of glibc-2.2.1-3.i686, the problem goes away.  
So it's specific to the i686 glibc.
Comment 8 Glen Foster 2001-01-29 19:01:33 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 9 Bernhard Rosenkraenzer 2001-02-06 12:06:37 EST
*** Bug 26297 has been marked as a duplicate of this bug. ***
Comment 10 Bernhard Rosenkraenzer 2001-02-07 11:22:23 EST
*** Bug 26456 has been marked as a duplicate of this bug. ***
Comment 11 Bernhard Rosenkraenzer 2001-02-11 11:23:18 EST
*** Bug 27054 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Jelinek 2001-02-12 04:30:54 EST
glibc-2.2.1-7 makes sure __pthread_initialize_minimal is called even when
dlopening a library linked against -lpthread from program not linked against
it.
No matter what, this is playing with fire and either the libraries should
not be linked against -lpthread (there is actually no reason in this case,
I've provided patches for Mesa) or kdm should be linked against -lpthread.
Comment 13 Bernhard Rosenkraenzer 2001-02-20 12:50:17 EST
*** Bug 28429 has been marked as a duplicate of this bug. ***
Comment 14 Bernhard Rosenkraenzer 2001-02-20 12:54:08 EST
*** Bug 28431 has been marked as a duplicate of this bug. ***
Comment 15 Bernhard Rosenkraenzer 2001-02-20 12:56:12 EST
*** Bug 28308 has been marked as a duplicate of this bug. ***
Comment 16 Bernhard Rosenkraenzer 2001-02-24 14:23:37 EST
*** Bug 29204 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.