Bug 251847 - iwl3945 driver doesn't lit Wifi-LED in laptop IBM T60
iwl3945 driver doesn't lit Wifi-LED in laptop IBM T60
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 361261 378511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-12 08:04 EDT by Pakhom
Modified: 2008-04-02 10:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 10:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pakhom 2007-08-12 08:04:37 EDT
Description of problem:
Wi-Fi network work fine but Wifi_LED on front panel doesn't lit. When I used
windows this wifi-LED is lit.

Version-Release number of selected component (if applicable):
driver iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for
Linux, 0.1.5kd

uname -a
Linux localhost.localdomain 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:10:34 EDT 2007
i686 i686 i386 GNU/Linux

# lsmod | grep 3945
iwl3945               161829  0 
mac80211              147017  1 iwl3945

# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3
(rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
15:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
Comment 1 Deependra Singh Shekhawat 2007-08-27 01:26:48 EDT
I am also having the same problem I am using the following versions of required
packages
kernel-2.6.22.4-65.fc7
iwl3945 version is 0.1.8kd

My uname -a is :
Linux localhost 2.6.22.4-65.fc7 #1 SMP Tue Aug 21 22:36:56 EDT 2007 i686 i686
i386 GNU/Linux

My laptop is 
Lenovo 3000N100-07684KA

Wireless works with no problem (iwl3945) but the wireless LED never shows up.
Comment 2 Ian Malone 2007-09-10 11:20:55 EDT
Same here, Sony VGN-C2M/W.  Intel 3945abg Pro NIC. Kernel 2.6.22.4-65.fc7.

LED works under Win-Vista or F7 with ipw3945 driver.

Seem to remember reading somewhere this is a known upstream problem/limitation?
Comment 3 John W. Linville 2007-10-22 10:02:04 EDT
Would you mind testing these F8-based kernels?

   http://koji.fedoraproject.org/koji/taskinfo?taskID=203296

Do they improve the situation for you?
Comment 4 Pakhom 2007-10-22 13:15:17 EDT
Thanks for your support.
I like to testing these F8-based kernels. Please provide me information how I
will try to install F8-based kernels?
Comment 5 Pakhom 2007-10-27 16:51:36 EDT
I have installed the kernel 2.6.23.1-10.fc7 but problem still the same.

uname -a
Linux localhost.localdomain 2.6.23.1-10.fc7 #1 SMP Fri Oct 19 15:39:08 EDT 2007
i686 i686 i386 GNU/Linux
Comment 6 Jason Taylor 2007-10-28 11:51:16 EDT
This is also a problem for me. Dell M1710.

Linux bruiser.localdomain 2.6.23.1-37.fc8 #1 SMP Fri Oct 26 12:36:34 EDT 2007
i686 i686 i386 GNU/Linux
Comment 7 John W. Linville 2007-10-29 14:11:54 EDT
FYI...LED handling code for iwlwifi has not been sent upstream.  They appear 
to be working on it now, so stay tuned...
Comment 8 Pakhom 2007-11-17 07:17:41 EST
I installed FC8 and problem still the same.
uname -a
Linux localhost.localdomain 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007
i686 i686 i386 GNU/Linux
Comment 9 John W. Linville 2007-11-17 21:47:46 EST
The situation hasn't changed since comment 7...
Comment 10 Jim Roland 2007-12-09 16:26:20 EST
Also having issue with Dell Latitude D620, same chipset using iwl3945 driver
(Intel older versions with daemon ipw3945d works, but iwl3945 faster & more
stable on connection, but no LED status).

uname -a
Linux localhost.localdomain 2.6.23.8-63.fc8 #1 SMP Wed Nov 21 18:10:47 EST 2007
i686 i686 i386 GNU/Linux
Comment 11 John W. Linville 2007-12-10 11:43:44 EST
I'm glad to hear that iwl3945 is working so well for most people.  Now if we 
could just convince Intel to make their LEDs work with their driver...
Comment 12 Laurent Rineau 2007-12-20 05:37:18 EST
I have a Dell D830. Using iwl3945, the WLAN works great, but the Wifi LED.
Comment 13 John W. Linville 2008-01-17 12:08:03 EST
*** Bug 361261 has been marked as a duplicate of this bug. ***
Comment 14 John W. Linville 2008-02-11 09:23:32 EST
*** Bug 378511 has been marked as a duplicate of this bug. ***
Comment 15 John W. Linville 2008-02-25 16:02:47 EST
http://bughost.org/bugzilla/show_bug.cgi?id=1209
Comment 16 John W. Linville 2008-04-02 10:16:03 EDT
These kernels now how LED support for iwl3945 and iwl4965:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=44217

   http://koji.fedoraproject.org/koji/buildinfo?buildID=44544

Given the nature of this issue, I'm going to close this now as RAWHIDE based 
on reports from several people that this indeed makes the LED do _something_.  
If anyone wants to complain about what it actually does now, please open 
individual bugs... :-)

Note You need to log in before you can comment on or make changes to this bug.