Bug 251908 - httpd should provide or depend on /etc/mime.types
Summary: httpd should provide or depend on /etc/mime.types
Status: CLOSED DUPLICATE of bug 249223
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-13 12:58 UTC by Andy Burns
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 12:37:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Burns 2007-08-13 12:58:16 UTC
Description of problem:

I installed a fairly minimal fedora7 (in a xen domU using virt-install and
kickstart but that should be irrelevant)

ran a "yum update"
ran "yum install httpd"
"service httpd start" refuses to start due to missing /etc/mime.types

tried manually installing shared-mime-info, thinking it might provide the file
and be a missing dependency, but no difference.

Version-Release number of selected component (if applicable):

httpd.x86_64                             2.2.4-4.1.fc7

Comment 1 Andy Burns 2007-08-13 13:06:18 UTC
did an "rpm -q -f /etc/mime.types" on another server to find the package owning
the file

then did a "yum install mailcap" on the server with the problem, httpd now
starts properly, is this a missing dependency in the httpd package, or a problem
with yum failing to install the dependency?



Comment 2 Joe Orton 2007-08-29 12:37:38 UTC

*** This bug has been marked as a duplicate of 249223 ***


Note You need to log in before you can comment on or make changes to this bug.