Bug 249223 - httpd install dependency missing (mailcap)
Summary: httpd install dependency missing (mailcap)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 249224 251908 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-23 02:33 UTC by Sergio Freire
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 2.2.6-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 22:32:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergio Freire 2007-07-23 02:33:53 UTC
Description of problem:
The httpd package does not check for the mailcap dependency, so you can have 
httpd installed but it does not run since the file /etc/mime.types is not found.

Version-Release number of selected component (if applicable):


How reproducible:
always.

Steps to Reproduce:
1. uninstall mailcap
2. uninstall httpd
3. install httpd
4. start httpd

Actual results:
fails, in /etc/httpd/error_log there is a message "could not open mime types 
config file /etc/mime.types."

Expected results:
server httpd should start.

Additional info:

Comment 1 Sergio Freire 2007-07-23 02:41:25 UTC
*** Bug 249224 has been marked as a duplicate of this bug. ***

Comment 2 Joe Orton 2007-08-29 12:37:55 UTC
*** Bug 251908 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2007-09-13 17:20:54 UTC
This should be fixed in 2.2.4-8.

Comment 4 Fedora Update System 2007-09-18 22:32:14 UTC
httpd-2.2.6-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.