Bug 251933 - ISE on Manage Software Channels -> Errata -> Add, traceback Can't locate object method "navi_empty_set" via package "Sniglets::Lists" (perhaps you forgot to load "Sniglets::Lists"?)
ISE on Manage Software Channels -> Errata -> Add, traceback Can't locate obje...
Status: CLOSED DUPLICATE of bug 368551
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
500
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McCune
Brandon Perkins
http://rlx-1-12.rhndev.redhat.com/net...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 11:27 EDT by Jan Pazdziora
Modified: 2008-08-21 12:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 11:04:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2007-08-13 11:27:18 EDT
Description of problem:

When you click on

http://rlx-1-12.rhndev.redhat.com/network/software/channels/manage/errata/clone.pxt?cid=162

and then on Add, you get 500 Error - Internal Server Error.

Version-Release number of selected component (if applicable):

RHN Satellite 5.0.0.

How reproducible:

Seemed deterministic for me but for the best results, restart the httpd before
trying, as the use Sniglets::Lists could be done by some other code.

Steps to Reproduce:
1. Restart httpd.
2. Go to the URL above.
3. Click add.
  
Actual results:

500 Error - Internal Server Error and a traceback

The following exception occured while executing this request:
 GET
/network/software/channels/manage/errata/add.pxt?manage_channel_navi_node=add_channel_errata&cid=162
HTTP/1.1 (from browser)
 /network/software/channels/manage/errata/add.pxt (from Apache)

Date:
  Thu Aug  9 17:42:25 2007

Headers:
  Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: keep-alive
  Cookie: s_vi=[CS]v1|4635FA9500003C6F-A160B61000017FA[CE]; s_cc=true;
s_sq=%5B%5BB%5D%5D; rh_user=cperry94|Clifford|customer|;
pxt-session-cookie=138x513393327303a2050545469b304270fc
  Host: rlx-1-12.rhndev.redhat.com
  Keep-Alive: 300
  Referer:
http://rlx-1-12.rhndev.redhat.com/network/software/channels/manage/errata/clone.pxt?cid=162
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10)
Gecko/20070221 Red Hat/1.5.0.10-0.1.el4 Firefox/1.5.0.10

Form variables:
  cid => 162
  manage_channel_navi_node => 

User Information:
  User admin (id 1, org_id 1)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  Can't locate object method "navi_empty_set" via package "Sniglets::Lists"
(perhaps you forgot to load "Sniglets::Lists"?) at
/usr/lib/perl5/site_perl/5.8.5/Sniglets/Navi/Node.pm line 70.

Expected results:

No error.

Additional info:
Comment 3 Jan Pazdziora 2008-08-19 11:04:19 EDT
You cannot because Justin has fixed in

http://svn.rhndev.redhat.com/viewcvs/trunk/eng/web/modules/sniglets/Sniglets/Navi/Node.pm?rev=133537&r1=59372&r2=133537

as part of fix for bugzilla 368551.

I'd claim that this bugzilla has a much nicer problem description. Sod.

Closing as dupe.

*** This bug has been marked as a duplicate of bug 368551 ***

Note You need to log in before you can comment on or make changes to this bug.