Bug 252150 - can't move lvs out from a metadatacopies=0 pv
can't move lvs out from a metadatacopies=0 pv
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Zdenek Kabelac
Corey Marthaler
:
: 252151 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-14 06:32 EDT by Janne Peltonen
Modified: 2010-01-11 22:51 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0378
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Janne Peltonen 2007-08-14 06:32:29 EDT
Description of problem:

If I try to pvmove lv's out of a pv I created using the metadatacopies 0
option, pvmove concludes that the source physical volume is not in a
volume group and refuses to commence with the move. This is, at least, within a
clustered vg.

Version-Release number of selected component (if applicable):

lvm2-2.02.16-3.el5
lvm2-cluster-2.02.16-3.el5

How reproducible:

Steps to Reproduce:
1. create some physical volumes with the --metadatacopies 0 option
2. add these pvs into a vg
3. create some lvs in these pvs / pvmove some (extents of) existing lvs into
these new pvs
4. try to pvmove the extents out from these new pvs
  
Actual results:

pvmove says the pv isn't in a volume group, gives usage and exits

Expected results:

pvmove should move the lvs (extents) from the metadatacopies 0 pv into another pv
Comment 1 Milan Broz 2007-08-14 06:50:21 EDT
*** Bug 252151 has been marked as a duplicate of this bug. ***
Comment 2 Milan Broz 2007-08-14 07:38:04 EDT
Yes, this need to be fixed, simply reproducible on RHEL5.
Comment 4 Alasdair Kergon 2007-08-14 08:44:18 EDT
It's another (well-hidden!) pv_read() that needs changing, like some others 
already have been fixed in the tools directory.  This one is certainly 
fixable, but it is not trivial.  (It should do sequence of functions calls to 
determine VG first, and only rely on pv_read() output when it's proven not to 
belong to any VG.  Maybe the function should be removed.  Long term we're 
trying to get rid of 'pv_read()'.)
Comment 5 RHEL Product and Program Management 2007-10-15 23:49:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Milan Broz 2008-01-17 19:23:28 EST
In lvm2-2.02.30-1.el5.
Comment 11 errata-xmlrpc 2008-05-21 11:39:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0378.html

Note You need to log in before you can comment on or make changes to this bug.