Bug 252151 - can't move lvs out from a metadatacopies=0 pv
Summary: can't move lvs out from a metadatacopies=0 pv
Status: CLOSED DUPLICATE of bug 252150
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
high
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-14 10:37 UTC by Janne Peltonen
Modified: 2013-03-01 04:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 10:50:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Janne Peltonen 2007-08-14 10:37:32 UTC
Description of problem:

If I try to pvmove lv's out of a pv I created using the metadatacopies 0
option, pvmove concludes that the source physical volume is not in a
volume group and refuses to commence with the move. This is, at least, within a
clustered vg.

Version-Release number of selected component (if applicable):

lvm2-2.02.16-3.el5
lvm2-cluster-2.02.16-3.el5

How reproducible:

Steps to Reproduce:
1. create some physical volumes with the --metadatacopies 0 option
2. add these pvs into a vg
3. create some lvs in these pvs / pvmove some (extents of) existing lvs into
these new pvs
4. try to pvmove the extents out from these new pvs
  
Actual results:

pvmove says the pv isn't in a volume group, gives usage and exits

Expected results:

pvmove should move the lvs (extents) from the metadatacopies 0 pv into another pv

Comment 1 Milan Broz 2007-08-14 10:50:15 UTC

*** This bug has been marked as a duplicate of 252150 ***


Note You need to log in before you can comment on or make changes to this bug.