Bug 252413 - Fix sound for Lenovo Thinkpad's T61/X61
Fix sound for Lenovo Thinkpad's T61/X61
Status: CLOSED DUPLICATE of bug 252373
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: Brian Maly
Martin Jenner
: Patch
Depends On: 254233
Blocks: 246139 418031 410251
  Show dependency treegraph
 
Reported: 2007-08-15 17:42 EDT by Traxtopel
Modified: 2008-04-03 14:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 14:07:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log for F7 (updates applied) on T61 (58.58 KB, text/plain)
2007-08-24 17:00 EDT, Matthew Saltzman
no flags Details
T61_dmidecode.larry (13.85 KB, application/octet-stream)
2008-01-18 14:58 EST, Larry Troan
no flags Details
X61_dmidecode.larry (13.19 KB, application/octet-stream)
2008-01-18 14:59 EST, Larry Troan
no flags Details
dmidecode of my X61 as requested (13.19 KB, application/octet-stream)
2008-02-14 05:09 EST, Jan Wildeboer
no flags Details

  None (edit)
Description Traxtopel 2007-08-15 17:42:54 EDT
Description of problem:
On a T61 sound does not work with RHEL5 U1, can be fixed by adding the following
patch.

http://hg.alsa-project.org/alsa-kernel/rev/ca37aeeeb0ea

More information found here
http://www.fedoraforum.org/forum/showthread.php?t=159516

Patch
--- a/pci/hda/patch_analog.c	Fri Jun 08 11:41:34 2007 +0200
+++ b/pci/hda/patch_analog.c	Fri Jun 08 12:25:25 2007 +0200
@@ -2982,6 +2982,8 @@ static struct snd_kcontrol_new ad1984_th
 	HDA_CODEC_VOLUME("Mic Boost", 0x14, 0x0, HDA_INPUT),
 	HDA_CODEC_VOLUME("Internal Mic Boost", 0x15, 0x0, HDA_INPUT),
 	HDA_CODEC_VOLUME("Docking Mic Boost", 0x25, 0x0, HDA_OUTPUT),
+	HDA_CODEC_VOLUME("Beep Playback Volume", 0x20, 0x03, HDA_INPUT),
+	HDA_CODEC_MUTE("Beep Playback Switch", 0x20, 0x03, HDA_INPUT),
 	HDA_CODEC_VOLUME("Capture Volume", 0x0c, 0x0, HDA_OUTPUT),
 	HDA_CODEC_MUTE("Capture Switch", 0x0c, 0x0, HDA_OUTPUT),
 	HDA_CODEC_VOLUME_IDX("Capture Volume", 1, 0x0d, 0x0, HDA_OUTPUT),
@@ -3011,6 +3013,8 @@ static struct hda_verb ad1984_thinkpad_i
 	{0x25, AC_VERB_SET_AMP_GAIN_MUTE, AMP_OUT_MUTE},
 	/* Analog mixer - docking mic; mute as default */
 	{0x20, AC_VERB_SET_AMP_GAIN_MUTE, AMP_IN_MUTE(4)},
+	/* enable EAPD bit */
+	{0x12, AC_VERB_SET_EAPD_BTLENABLE, 0x02},
 	{ } /* end */
 };
Comment 1 Peter Martuccelli 2007-08-16 10:23:18 EDT
Dup of bug 249388 and bug 252373, close out as a dup when final patch is submitted.
Comment 2 Traxtopel 2007-08-24 07:37:56 EDT
I see that patch is applied to 2.6.18-43.el5, however still does not produce any
sound. Comment from fedora forum is you require.

The line in /etc/modprobe.conf that current looks like
options snd-hda-intel index=0
needs to be changed so that it looks like...
options snd-hda-intel index=0 model=thinkpad

We have tested this on both a t61 & t61p and this works.

Is there any chance a workaround can be created so this is no longer necessary.
Comment 3 Matthew Saltzman 2007-08-24 16:22:01 EDT
Also affects F7 kernels through kernel-2.6.22.4-65.fc7.
Comment 4 Matthew Saltzman 2007-08-24 16:25:08 EDT
And the workaround in Comment #2 does not help on F7.
Comment 5 Traxtopel 2007-08-24 16:51:44 EDT
I should of mentioned, you open "volume control" and enable the speaker.
Comment 6 Matthew Saltzman 2007-08-24 17:00:33 EDT
Created attachment 172457 [details]
scsconfig.log for F7 (updates applied) on T61
Comment 7 Matthew Saltzman 2007-08-24 17:01:51 EDT
(In reply to comment #5)
> I should of mentioned, you open "volume control" and enable the speaker.

I open the volume control and only see the Playback tab and Master control.  It
is not muted and volume is up full.

scsconfig.log attached.
Comment 8 Traxtopel 2007-08-24 17:03:16 EDT
Matthew this ticket is/was opened for RHEL5 U1 not FC7. 
Comment 9 Matthew Saltzman 2007-08-24 17:25:10 EDT
OK cloned under F7.  Hope that's the right thing to do.
Comment 10 Dax Kelson 2007-09-05 15:15:52 EDT
(In reply to comment #2)
> 
> The line in /etc/modprobe.conf that current looks like
> options snd-hda-intel index=0
> needs to be changed so that it looks like...
> options snd-hda-intel index=0 model=thinkpad
> 
> We have tested this on both a t61 & t61p and this works.
> 
> Is there any chance a workaround can be created so this is no longer necessary.

On my T61p I updated all of ALSA to 1.0.15rc1 and now the sound in my T61p works
fine. I didn't have to touch my stock modprobe.conf.
Comment 13 Larry Troan 2008-01-17 11:27:58 EST
Just tried to recreate on my T61 with x86_64 kernel from 5.1
(kernel-2.6.18-53.el5 SMP). WORKSFORME.

PCM device AD198x Analog
Driver snd-hda-intel

lspci -vv |grep Audio
00:16.0 Audio Device Intel Conntroller 82801H (ICH8 family) HD audio controller
(rev 3). 

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.14rc3 (Wed Mar 14 07:25:50
2007 UTC)

cat /proc/asound/modules
0 snd_hda_intel


Can't try xen kernel due to bug 372741 which is scheduled to be fixed in 5.2.

Will try x86 install next with and without xen.....
Comment 14 Larry Troan 2008-01-17 15:37:12 EST
x86 xen, PAE and kernel all have sound working in RHEL5.1. Will try X61 next.

Sound on my T61 appears to work fine.
Comment 15 Larry Troan 2008-01-18 14:44:31 EST
Just tried sound on my X61 x86 kernel and it works fine with RHEL5.1.
Sound on my X61 appears to work fine.

Same hardware/software as comment #13. Obtaining dmidecode output from both
systems and will append to this bug.

Comment 16 Larry Troan 2008-01-18 14:51:13 EST
Comment #9 From Matthew Saltzman (mjs@clemson.edu)....
Cloned bug referred to in that comment under F7 is bug 254233 which is
CLOSED=RAWHIDE.
Comment 17 Larry Troan 2008-01-18 14:58:45 EST
Created attachment 292191 [details]
T61_dmidecode.larry
Comment 18 Larry Troan 2008-01-18 14:59:15 EST
Created attachment 292192 [details]
X61_dmidecode.larry
Comment 19 RHEL Product and Program Management 2008-02-01 17:40:53 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 22 Larry Troan 2008-02-10 21:13:26 EST
Could you please provide dmidecode command output from your failing system to
this bugzilla.
Comment 23 Jan Wildeboer 2008-02-14 05:09:47 EST
Created attachment 294902 [details]
dmidecode of my X61 as requested

Added dmidecode from my X61

Jan
Comment 24 Jan Wildeboer 2008-02-14 05:12:58 EST
A diff of the dmidecode tells me that I might have to update my BIOS. Will do
and report if that helps.
Comment 25 Larry Troan 2008-02-20 15:56:50 EST
Latest BIOS (for a different bug) per Yoshiyama-san at Lenovo is as follows:
On Thu, 2008-02-07 at 09:35 +0900, Noritoshi Yoshiyama wrote:
? 372741 [ON_QA] Lenovo T61/X61 lock up with xen kernel.
>                 Not sure exactly which one is the root. 
>                 The latest  BIOS on web shoud have fixed USB spurious 
> interrupts . Please make sure Version 7NETA6WW (2.06)
>                 
> http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67982
>  
>  
>                 X61 - With the -61 still no luck on my X61. The moment X 
> starts - cold reset. I *guess* this is more a x11-driver problem then it 
> is a kernel prob as booting to runlevel 3 works.
>                 T61  Odd.  When I was doing the testing on the R61 and 
> T61, X worked just fine
> 
> 
> X61
> http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67982
> 
> T61/T61p:
> http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67988
> 
> R61 ( some of R61s)
> http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67988
> 
> 
> --------------
> http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=TPAD-MATRIX
Comment 26 Jan Wildeboer 2008-03-07 04:18:07 EST
I am now on 2.06. Updating BIOS on X61 is a *big* problem, BTW. Only works woth
optical drive in docking station, not with standard USB CD drive.

So with 2.06, still no sound.

Jan
Comment 28 Larry Troan 2008-03-07 15:40:18 EST
Comment #26 satisfies NEEDINFO. Setting to ASSIGNED.
Comment 29 Peter Martuccelli 2008-04-03 14:07:02 EDT

*** This bug has been marked as a duplicate of 252373 ***

Note You need to log in before you can comment on or make changes to this bug.