Bug 254233 - Fix sound for Lenovo Thinkpad's T61/X61
Fix sound for Lenovo Thinkpad's T61/X61
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 265901 274021 (view as bug list)
Depends On:
Blocks: 252413
  Show dependency treegraph
 
Reported: 2007-08-24 17:24 EDT by Matthew Saltzman
Modified: 2008-01-18 14:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-30 17:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log for F7 (updates applied) on T61 (58.58 KB, text/plain)
2007-08-24 17:24 EDT, Matthew Saltzman
no flags Details

  None (edit)
Description Matthew Saltzman 2007-08-24 17:24:11 EDT
+++ This bug was initially created as a clone of Bug #252413 +++

The following issue applies to F7 as well.

Description of problem:
On a T61 sound does not work with RHEL5 U1, can be fixed by adding the following
patch.

http://hg.alsa-project.org/alsa-kernel/rev/ca37aeeeb0ea

More information found here
http://www.fedoraforum.org/forum/showthread.php?t=159516

Patch
--- a/pci/hda/patch_analog.c	Fri Jun 08 11:41:34 2007 +0200
+++ b/pci/hda/patch_analog.c	Fri Jun 08 12:25:25 2007 +0200
@@ -2982,6 +2982,8 @@ static struct snd_kcontrol_new ad1984_th
 	HDA_CODEC_VOLUME("Mic Boost", 0x14, 0x0, HDA_INPUT),
 	HDA_CODEC_VOLUME("Internal Mic Boost", 0x15, 0x0, HDA_INPUT),
 	HDA_CODEC_VOLUME("Docking Mic Boost", 0x25, 0x0, HDA_OUTPUT),
+	HDA_CODEC_VOLUME("Beep Playback Volume", 0x20, 0x03, HDA_INPUT),
+	HDA_CODEC_MUTE("Beep Playback Switch", 0x20, 0x03, HDA_INPUT),
 	HDA_CODEC_VOLUME("Capture Volume", 0x0c, 0x0, HDA_OUTPUT),
 	HDA_CODEC_MUTE("Capture Switch", 0x0c, 0x0, HDA_OUTPUT),
 	HDA_CODEC_VOLUME_IDX("Capture Volume", 1, 0x0d, 0x0, HDA_OUTPUT),
@@ -3011,6 +3013,8 @@ static struct hda_verb ad1984_thinkpad_i
 	{0x25, AC_VERB_SET_AMP_GAIN_MUTE, AMP_OUT_MUTE},
 	/* Analog mixer - docking mic; mute as default */
 	{0x20, AC_VERB_SET_AMP_GAIN_MUTE, AMP_IN_MUTE(4)},
+	/* enable EAPD bit */
+	{0x12, AC_VERB_SET_EAPD_BTLENABLE, 0x02},
 	{ } /* end */
 };

-- Additional comment from peterm@redhat.com on 2007-08-16 10:23 EST --
Dup of bug 249388 and bug 252373, close out as a dup when final patch is submitted.

-- Additional comment from traxtopel@fastmail.fm on 2007-08-24 07:37 EST --
I see that patch is applied to 2.6.18-43.el5, however still does not produce any
sound. Comment from fedora forum is you require.

The line in /etc/modprobe.conf that current looks like
options snd-hda-intel index=0
needs to be changed so that it looks like...
options snd-hda-intel index=0 model=thinkpad

We have tested this on both a t61 & t61p and this works.

Is there any chance a workaround can be created so this is no longer necessary.

-- Additional comment from mjs@clemson.edu on 2007-08-24 16:22 EST --
Also affects F7 kernels through kernel-2.6.22.4-65.fc7.

-- Additional comment from mjs@clemson.edu on 2007-08-24 16:25 EST --
And the workaround in Comment #2 does not help on F7.

-- Additional comment from traxtopel@fastmail.fm on 2007-08-24 16:51 EST --
I should of mentioned, you open "volume control" and enable the speaker.

-- Additional comment from mjs@clemson.edu on 2007-08-24 17:00 EST --
Created an attachment (id=172457)
scsconfig.log for F7 (updates applied) on T61


-- Additional comment from mjs@clemson.edu on 2007-08-24 17:01 EST --
(In reply to comment #5)
> I should of mentioned, you open "volume control" and enable the speaker.

I open the volume control and only see the Playback tab and Master control.  It
is not muted and volume is up full.

scsconfig.log attached.

-- Additional comment from traxtopel@fastmail.fm on 2007-08-24 17:03 EST --
Matthew this ticket is/was opened for RHEL5 U1 not FC7.
Comment 1 Matthew Saltzman 2007-08-24 17:24:11 EDT
Created attachment 172459 [details]
scsconfig.log for F7 (updates applied) on T61
Comment 2 Chuck Ebbert 2007-08-28 15:20:29 EDT
There is no support at all for the ad1984 codec in 2.6.22. So this fix will have
to wait for a 2.6.23 kernel for F7.
Comment 3 Dax Kelson 2007-09-05 15:13:34 EDT
(In reply to comment)
> The line in /etc/modprobe.conf that current looks like
> options snd-hda-intel index=0
> needs to be changed so that it looks like...
> options snd-hda-intel index=0 model=thinkpad

I updated to ALSA 1.0.15rc1 and now such change to modprobe.conf was required.
All sounds works fine now. I have a T61p.
Comment 4 Martin Stransky 2007-09-10 05:45:47 EDT
*** Bug 274021 has been marked as a duplicate of this bug. ***
Comment 5 Martin Stransky 2007-09-10 06:12:29 EDT
*** Bug 265901 has been marked as a duplicate of this bug. ***
Comment 6 Christopher Brown 2007-09-30 08:52:29 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. As Chuck has indicated
this issue may be resolved in 2.6.23, could you possibly test with the latest
kernel from rawhide and see if this is the case?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged following the release of
2.6.23
Comment 7 Ranjan Maitra 2007-09-30 11:44:41 EDT
thanks! i will wait for 2.6.23 then. we are now in 2.6.22-9
Comment 8 Matthew Saltzman 2007-09-30 16:57:54 EDT
I can confirm that the Fedora 8 Test 2 kernels (2.6.23) resolve this problem.
Comment 9 Christopher Brown 2007-09-30 17:41:57 EDT
Thanks for confirming Matthew. I'll close with comments to that effect. Please
re-open if the update to 2.6.23 does not resolve the issue in F7.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.