Bug 252451 - Pidgin howl dependency broken for 2.1.0-2.fc7
Pidgin howl dependency broken for 2.1.0-2.fc7
Status: CLOSED DUPLICATE of bug 253199
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
7
All Linux
high Severity high
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 23:26 EDT by Peter Lawler
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 10:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Lawler 2007-08-15 23:26:39 EDT
Description of problem:
Cannot update from Pidgin 2.0.1-1.fc7 to 2.0.1-2.fc7, missing dependency on libhowl.

Version-Release number of selected component (if applicable):
One of the two listed above.

How reproduce:
$yum update pidgin


Steps to Reproduce:
1. yum update pidgin
2. watch it fail

  
Actual results:
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package pidgin.i386 0:2.1.0-2.fc7 set to be updated
--> Processing Dependency: libpurple = 2.1.0-2.fc7 for package: pidgin
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package pidgin.i386 0:2.1.0-2.fc7 set to be updated
---> Package libpurple.i386 0:2.1.0-2.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 pidgin                  i386       2.1.0-2.fc7      updates           1.5 M
Updating for dependencies:
 libpurple               i386       2.1.0-2.fc7      updates           6.1 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)         

Total download size: 7.6 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
--> Populating transaction set with selected packages. Please wait.
---> Package pidgin.i386 0:2.1.0-2.fc7 set to be updated
---> Package libpurple.i386 0:2.1.0-2.fc7 set to be updated
ERROR with rpm_check_debug vs depsolve:
Package libpurple needs libhowl.so.0, this is not available.
Complete!



Expected results:
It updates

Additional info:
Comment 1 Peter Lawler 2007-08-15 23:27:45 EDT
Yes, I should've labelled them all as 2.1.0 and not 2.0.1. I blame my DB
lecturer this morning for putting me to sleep.
Comment 2 Peter Lawler 2007-08-16 10:38:50 EDT
I managed to get hold of Nosnilmot on IRC, he first asked me if there was a
/usr/lib*/purple-2/bounjour.so, which there wasn't.

I then followed his instructions ("maybe bad meta data, install the
avahi-compat-howl, then try"), did a 'yum clean all', 'yum install
avahi-compat-howl', 'yum update pidgin', worked.

Leaving open so as to ascertain why the avahi-compat-howl foo is happening.
Comment 3 Warren Togami 2007-08-17 10:58:47 EDT

*** This bug has been marked as a duplicate of 253199 ***

Note You need to log in before you can comment on or make changes to this bug.