Bug 253199 - Yum update to Pidgin 2.1.0-2 has unresolved dependencies
Yum update to Pidgin 2.1.0-2 has unresolved dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: Reopened
: 252451 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 08:59 EDT by Stephen Gallagher
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 13:50:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum -d6 -y update (23.36 KB, text/plain)
2007-09-04 07:15 EDT, Stephen Gallagher
no flags Details

  None (edit)
Description Stephen Gallagher 2007-08-17 08:59:05 EDT
Description of problem:
Attempting to perform "yum update pidgin" yields the following error:
ERROR with rpm_check_debug vs depsolve:
Package pidgin needs libebook-1.2.so.9, this is not available.
Package pidgin needs libedata-book-1.2.so.2, this is not available.
Package pidgin needs libedataserver-1.2.so.9, this is not available.
Package pidgin needs libgtkspell.so.0, this is not available.


Version-Release number of selected component (if applicable):
Pidgin 2.1.0-2

How reproducible:
Every time, as long as the evolution-data-server and gtkspell packages are not
installed

Steps to Reproduce:
1. Set up a system without gtkspell and evolution-data-server installed
2. Attempt to perform a 'yum update pidgin' to version 2.1.0-2
  
Actual results:
ERROR with rpm_check_debug vs depsolve:
Package pidgin needs libebook-1.2.so.9, this is not available.
Package pidgin needs libedata-book-1.2.so.2, this is not available.
Package pidgin needs libedataserver-1.2.so.9, this is not available.
Package pidgin needs libgtkspell.so.0, this is not available.



Expected results:
=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 pidgin                  i386       2.1.0-2.fc7      updates           1.5 M
Installing for dependencies:
 NetworkManager-glib     i386       1:0.6.5-7.fc7    updates            30 k
 avahi-compat-howl       i386       0.6.17-1.fc7     fedora             29 k
 cyrus-sasl-md5          i386       2.1.22-6         fedora             47 k
 libpurple               i386       2.1.0-2.fc7      updates           6.1 M
 libsilc                 i386       1.0.2-2.fc6      fedora            412 k

Transaction Summary
=============================================================================
Install      5 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Additional info:
It looks like there's some confusion on where to find the dependent libraries.
Pidgin should depend on evolution-data-server and gtkspell, rather than the
specific libraries. Or else there needs to be a better lookup for what package
contains those libraries.
Comment 1 Warren Togami 2007-08-17 10:58:50 EDT
*** Bug 252451 has been marked as a duplicate of this bug. ***
Comment 2 Warren Togami 2007-08-17 10:59:59 EDT
As far as we can tell, this isn't a problem in pidgin.  A yum bug?
Comment 3 Seth Vidal 2007-08-17 11:19:45 EDT
this is yum 3.2.2?
Comment 4 Stephen Gallagher 2007-08-17 11:26:12 EDT
yum-3.2.2-1.fc7
Comment 5 Jeremy Katz 2007-08-20 13:56:09 EDT
What's the output of 'rpm -q evolution-data-server'?  And can you provide the
output of yum -d6 update pidgin?
Comment 6 Stephen Gallagher 2007-08-20 14:10:09 EDT
I'm unable to reproduce this at this point, because I manually installed
evolution-data-server and then updated pidgin.

I yum removed all of the components and attempted to yum install pidgin again,
but from a clean state, it recognizes that it needs evolution-data-server.

So it appears to happen only during upgrade from the previous version of pidgin.
Comment 7 Seth Vidal 2007-08-29 17:59:30 EDT
okay - I think the background reason for this was fixed this morning - so I'm
going to close the bug. open a new bug if something related happens again.

thank you
Comment 8 Stephen Gallagher 2007-09-04 07:14:29 EDT
Reopening this bug, as we still have a dependency resolution problem as of
today, 2007-09-04. I will attach a log file with the debug output of yum.
Comment 9 Stephen Gallagher 2007-09-04 07:15:48 EDT
Created attachment 186071 [details]
yum -d6 -y update

Log of the failed dependency resolution.
Comment 10 Jeremy Katz 2007-09-04 13:50:11 EDT
yum 3.2.4 should fix this; it should be available in -updates now

Note You need to log in before you can comment on or make changes to this bug.