Bug 252455 - Anacron %postun scriptlet exits with status 3 (condrestart -> restart)
Anacron %postun scriptlet exits with status 3 (condrestart -> restart)
Status: CLOSED DUPLICATE of bug 251757
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 00:09 EDT by Stewart Adam
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 03:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2007-08-16 00:09:50 EDT
Description of problem:
The %postun script fails when attempting to uninstall (or upgrade) anacron with
exit status 3. The cause is the line:
  service anacron condrestart >/dev/null 2>&1
as condrestart isn't recognized. 'condrestart' needs to be changed 'restart'

Version-Release number of selected component (if applicable):
anacron-2.3-47.fc7
anacron-2.3-49.fc8

How reproducible:
Always

Steps to Reproduce:
1. rpm -e anacron OR upgrade anacron from any of the versions above
  
Actual results:
The scriptlet fails, resulting in two or more version being installed at once

Expected results:
The scriptlet either works correctly or does not stop the package from
uninstalling upon failure

Additional info:
Comment 1 Marcela Mašláňová 2007-08-16 03:02:55 EDT

*** This bug has been marked as a duplicate of 251757 ***

Note You need to log in before you can comment on or make changes to this bug.