Bug 25255 - can't skip firewall config
Summary: can't skip firewall config
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard: Florence RC-1
Keywords:
: 25256 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 03:04 UTC by Jeremy Katz
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 22:00:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for skipping firewall config (429 bytes, patch)
2001-01-30 22:07 UTC, Jeremy Katz
no flags Details | Diff

Description Jeremy Katz 2001-01-30 03:04:52 UTC
If you create an install class which sets up some firewall rules, you can't
then skip the firewall config screen for the gui install because getNext()
doesn't do a sanity check for if it's values have been set.  Not a problem
with gui or kickstart.  Following patch fixes gui

--- anaconda/iw/firewall_gui.py~	Wed Jan 24 02:40:23 2001
+++ anaconda/anaconda/iw/firewall_gui.py	Mon Jan 29 20:09:12 2001
@@ -20,6 +20,9 @@
 #
	dev.set (("onboot", "yes"))

     def getNext (self):
+
if not self.__dict__.has_key("radio3"):
+
	return None
+
 #        print self.ports.get_text ()

         if self.radio3.get_active ():

Comment 1 Jeremy Katz 2001-01-30 03:06:39 UTC
*** Bug 25256 has been marked as a duplicate of this bug. ***

Comment 2 Michael Fulbright 2001-01-30 21:42:49 UTC
Could you attach the patch please, the above looks like it just adds 3 blank lines.

Comment 3 Jeremy Katz 2001-01-30 22:07:08 UTC
Created attachment 8519 [details]
patch for skipping firewall config

Comment 4 Michael Fulbright 2001-02-01 19:55:07 UTC
Thanks!

Forwarding to a developer.


Comment 5 Brent Fox 2001-02-08 22:00:45 UTC
I've applied the patch.  Brock, please try a kickstart install with an
appropriate kickstart file and see if the firewall screen is skipped as it
should be.


Note You need to log in before you can comment on or make changes to this bug.