This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 25256 - can't skip firewall config
can't skip firewall config
Status: CLOSED DUPLICATE of bug 25255
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-29 22:04 EST by Jeremy Katz
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-29 22:04:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2001-01-29 22:04:52 EST
If you create an install class which sets up some firewall rules, you can't
then skip the firewall config screen for the gui install because getNext()
doesn't do a sanity check for if it's values have been set.  Not a problem
with gui or kickstart.  Following patch fixes gui

--- anaconda/iw/firewall_gui.py~	Wed Jan 24 02:40:23 2001
+++ anaconda/anaconda/iw/firewall_gui.py	Mon Jan 29 20:09:12 2001
@@ -20,6 +20,9 @@
 #
	dev.set (("onboot", "yes"))

     def getNext (self):
+
if not self.__dict__.has_key("radio3"):
+
	return None
+
 #        print self.ports.get_text ()

         if self.radio3.get_active ():
Comment 1 Jeremy Katz 2001-01-29 22:06:43 EST
errr... not sure what happened there

*** This bug has been marked as a duplicate of 25255 ***

Note You need to log in before you can comment on or make changes to this bug.