This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 25267 - NIC does not get IP through DHCP
NIC does not get IP through DHCP
Status: CLOSED DUPLICATE of bug 24674
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 02:24 EST by albryan
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-31 01:40:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description albryan 2001-01-30 02:24:25 EST
egrep : egrep :No such file or directory.
egrep : ifcfg-ippp[0-9]+$ : No such file or directory.
-------------

I've been having minor probs after installing the 2.4.0 kernel rpm from the
redhat rawhide site. nothing major tho. I also compiled 2.4.0 on my own &
got the same errors.

since I started using 2.4.0, I've been getting startup/shutdown errors.

I have a 3com 509b nic for a cable modem (road runner). all I have to do is
set eth0 to dhcp & it has been working fine under linux. but once I
installed the new kernel, there was also a eth0:0 listed when I do netcfg &
eth0 didn't get my net connection at bootup.

right now, all I have to do to get it working is go into netcfg & click
activate on eth0 & it works fine. I removed eth0 & eth0:0, & on bootup it
redetected it as eth0, but eth0 still doesn't get an IP at bootup (YES,
ACTIVATE AT BOOTUP IS SELECTED along w/ DHCP)...I still have to click
activate, then it works.

here's the error at startup/shutdown:

egrep : egrep :No such file or directory.
egrep : ifcfg-ippp[0-9]+$ : No such file or directory.


Any idea how to fix it? like I said, no biggie but its a hassle.

thanks,
ant
Comment 1 Bernhard Rosenkraenzer 2001-01-30 06:25:40 EST
Looks like initscripts is passing bad parameters to egrep. Reassigning.

Comment 2 Bill Nottingham 2001-01-30 12:03:27 EST
What does /etc/sysconfig/network-scripts/ifcfg-eth0
(and /etc/sysconfig/network-scripts/ifcfg-eth0:0) say?
Comment 3 albryan 2001-01-31 01:40:40 EST
DEVICE=eth0
USERCTL=no
ONBOOT=yes
BOOTPROTO=dhcp
BROADCAST=
NETWORK=
NETMASK=
IPADDR=


----

There is no longer an ifcfg-eth0:0 because I removed eth0:0 w/ netcfg.
Comment 4 Bill Nottingham 2001-01-31 12:43:22 EST
Oh, this is the typo in init.d/network problem. See bug 24674; you
need to add a '|' just before the '\' on line 38 of /etc/init.d/network.

*** This bug has been marked as a duplicate of 24674 ***
Comment 5 albryan 2001-01-31 21:23:20 EST
That was indeed the problem. Thank you, Sirs!

Note You need to log in before you can comment on or make changes to this bug.