Bug 252943 - 5 channels are not supported in alsa
Summary: 5 channels are not supported in alsa
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.1
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Martuccelli
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
: 252942 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-16 08:04 UTC by Jane Lv
Modified: 2014-09-16 03:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 02:09:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/scsconfig.log (46.98 KB, application/octet-stream)
2007-09-11 08:27 UTC, Jane Lv
no flags Details

Description Jane Lv 2007-08-16 08:04:31 UTC
Description of problem:
I tested RHEL5.1-snapshot-1 kernel-2.6.18-37.el5-x86_64 on Intel Weybridge SDV 
platform.  The codec is SigmaTel STAC9274D.

When playing a 5 channels audio file, there is an error message "alsa-init: 5 
channels are not supported".  I checked 
file /proc/asound/card0/pcm0p/sub0/hw_params and found only 2 channels are 
open.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. Play the audio file,
[root@localhost ~]# mplayer fivechannels.wav
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU      6600  @ 2.40GHz (Family: 6, Model: 15, 
Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing fivechannels.wav.
Audio file file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 5 ch, s16le, 3528.0 kbit/100.00% (ratio: 441000->441000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or 
directory
alsa-init: 5 channels are not supported
AO: [alsa] 48000Hz 5ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.4 (00.3) of 0.7 (00.6)  1.3%

Exiting... (End of file)

2. At the same time, check hw_params,
[root@localhost ~]# cat /proc/asound/card0/pcm0p/sub0/hw_params
access: MMAP_INTERLEAVED
format: S16_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size: 1024
buffer_size: 16384
tick_time: 1000

[root@localhost ~]# file fivechannels.wav
fivechannels.wav: RIFF (little-endian) data, WAVE audio, 5 channels 44100 Hz

  
Actual results:
Only 2 channels are open.

Expected results:
5 channels are open.

Additional info:
The attached file is a 5 channels WAVE file with only data in center channel.  
So the expectation of playing this file is to get sound only in center 
channel.  From the current test result, there is no sound in center channel.

Comment 1 Jane Lv 2007-08-16 09:34:27 UTC
It's a duplicate of bug 252942.

Comment 2 Martin Stransky 2007-08-16 10:42:19 UTC
*** Bug 252942 has been marked as a duplicate of this bug. ***

Comment 3 Martin Stransky 2007-09-10 10:21:31 UTC
That's a driver/kernel problem. Moved there.

Comment 4 Martin Stransky 2007-09-10 10:24:02 UTC
Anyway, can you please attach /root/scsconfig.log? Is there any device what can
play 5-channel sound?

Comment 5 Jane Lv 2007-09-11 08:27:15 UTC
Created attachment 192351 [details]
/root/scsconfig.log

Log file, /root/scsconfig.log.

Comment 6 Jane Lv 2007-09-11 08:29:16 UTC
The file /root/scsconfig.log attached.  The sound device on my test machine 
(Intel Weybridge SDV platform) is Intel ICH9 HD audio controller.

Comment 7 Martin Stransky 2007-09-11 08:34:55 UTC
Yeah, the drivers don't export any multichannel device.

Comment 8 Brian Maly 2008-08-08 01:01:58 UTC
Can we test with a 5.2 kernel? The Sigmatel driver was updated (i.e. stac92xx) last release and may resolve the issue. If not a 5.3 pre-release kernel could be tested perhaps as the Sigmatel driver has again been updated with the most recent from upstream.

Comment 10 John Feeney 2013-11-04 02:09:12 UTC
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore is being closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide a sufficient business justification
in order to re-open it.


Note You need to log in before you can comment on or make changes to this bug.