Bug 252945 - Pirut Syntax Error on Start
Pirut Syntax Error on Start
Status: CLOSED DUPLICATE of bug 251836
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 04:09 EDT by Matteo G.
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 13:53:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matteo G. 2007-08-16 04:09:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
Component: pirut
Summary: TB27ac5246 <string>:68:__iter__:SyntaxError: no element found: line 1, column 0

Traceback (most recent call last):
  File "/usr/sbin/pup", line 650, in <module>
    main()
  File "/usr/sbin/pup", line 643, in main
    pup = PackageUpdater(not options.autoapply, options.config)
  File "/usr/sbin/pup", line 88, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 124, in __init__
    self.reset()
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 226, in reset
    self.doGroupSetup()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 413, in doGroupSetup
    self._up.doUpdates()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 461, in _getGroups
  File "/usr/lib/python2.5/site-packages/yum/comps.py", line 349, in add
    for event, elem in parser:
  File "<string>", line 68, in __iter__
SyntaxError: no element found: line 1, column 0

Local variables in innermost frame:
p: <XMLParser object at 0x9e10d10>
self: <iterparse object at 0x9e93acc>
b: <TreeBuilder object at 0x9e61bb8>
data: 
events: []

Version-Release number of selected component (if applicable):
pirut-1.3.9-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. Just try to start pirut
2.
3.

Actual Results:


Expected Results:


Additional info:
This problem started with an unnatural starting slowness of pup (a couple of minutes minimum).
Comment 1 Jeremy Katz 2007-08-20 13:53:14 EDT

*** This bug has been marked as a duplicate of 251836 ***

Note You need to log in before you can comment on or make changes to this bug.