Bug 25318 - [ACPI/APM] PE 1300 will not reboot
Summary: [ACPI/APM] PE 1300 will not reboot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 18:22 UTC by Becky Miller
Modified: 2007-04-18 16:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 22:08:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ksymoops decoded (8.65 KB, text/plain)
2001-03-30 22:08 UTC, Matt Domsch
no flags Details
Output of dmidecode for PE 1300 (4.91 KB, text/plain)
2001-04-20 22:05 UTC, John A. Hull
no flags Details

Description Becky Miller 2001-01-30 18:22:48 UTC
When the reboot command is given, the system halts normally then the 
message "Rebooting system" appears on the screen.  Nothing else happens.

Comment 1 Glen Foster 2001-01-30 20:43:33 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 2 Michael K. Johnson 2001-01-30 21:39:28 UTC
This is a common symptom of APM bios bugs.

Try booting with apm=no and see if that helps.

Comment 3 Michael K. Johnson 2001-02-09 00:37:27 UTC
If this is ACPI-related, it will probably just go away because
we have removed ACPI from the kernel builds for now.

Comment 4 Michael K. Johnson 2001-03-01 01:56:34 UTC
Please test with wolverine

Comment 5 Becky Miller 2001-03-13 21:49:21 UTC
This is still a problem.  We have tested with RC2 and QA0309.

Comment 6 Michael K. Johnson 2001-03-14 17:30:54 UTC
Has your testing included "apm=no"?  If so, let us know.  If not,
please test it.

In either case, please test "apm=realmode" as well and let us know
what you see.

Comment 7 Becky Miller 2001-03-14 23:36:31 UTC
Passing those parameters to the kernel has no effect. Problem happens only with 
the SMP kernel (APM is disabled). Reboot works correctly with UP kernel, where 
APM is turned on. Both kernels reboot probperly on other systems.

Comment 8 Arjan van de Ven 2001-03-15 13:53:38 UTC
Can you try adding one of the following items to lilo.conf as append= ?

reboot=c
reboot=h
reboot=b
reboot=w




Comment 9 John A. Hull 2001-03-21 18:39:35 UTC
None of the suggestions have worked

Comment 10 Matt Domsch 2001-03-30 22:08:23 UTC
Created attachment 14304 [details]
ksymoops decoded

Comment 11 Matt Domsch 2001-03-30 22:09:33 UTC
I've attached newt-oops.txt, a decoded oops, from qa0328, kernel
2.4.2-0.1.40BOOT.
-Matt

Comment 12 Matt Domsch 2001-03-30 22:12:22 UTC
Adding MKJ who has commented on this before.


Comment 13 Preston Brown 2001-04-03 14:03:03 UTC
Pasting oops into here directly:

Oops: 0000
CPU:    0
EIP:    0010:[<6d6f7264>]
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010286
eax: 00000000   ebx: f8a76924   ecx: 2560f680   edx: 00000000
esi: 00000000   edi: 00000001   ebp: bffffeb8   esp: f7ff5e90
ds: 0018   es: 0018   ss: 0018
Process linuxrc (pid: 8, stackpage=f7ff5000)
Stack: c011b3f1 f8a76924 00000001 00000000 f7ff4000 00000000 00000072 c011b6f6 
       c0274888 00000001 00000000 c011095d f7ff5eec f78d5090 c0242000 c0172b3c 
       f7ff4000 00000000 c0242000 c0261520 f7ff5ef8 00000286 f7ff5ef8 c01106ce 
Call Trace: [<c011b3f1>] [<f8a76924>] [<c011b6f6>] [<c011095d>] [<c0172b3c>]
[<c01106ce>] [<c0110600>] 
       [<c013c5d1>] [<c013cb25>] [<c012e9a5>] [<c0108ebf>] [<fee1dead>] 
Code:  Bad EIP value.

>>EIP; 6d6f7264 Before first symbol   <=====
Trace; c011b3f1 <notifier_chain_register+35/38>
Trace; f8a76924 <[cdrom].rodata.start+224/1b3f>
Trace; c011b6f6 <sys_reboot+8e/1c0>
Trace; c011095d <schedule+239/398>
Trace; c0172b3c <clear_buffer_attributes+c/78>
Trace; c01106ce <schedule_timeout+56/a0>
Trace; c0110600 <reschedule_idle+68/98>
Trace; c013c5d1 <sys_poll+61/2f8>
Trace; c013cb25 <locks_alloc_lock+35/48>
Trace; c012e9a5 <init_special_inode+25/b4>
Trace; c0108ebf <system_call+33/38>
Trace; fee1dead <END_OF_CODE+6381ab6/????>

Kernel panic: VFS: Unable to mount root fs on 08:41
Oops: 0000
CPU:    0
EIP:    0010:[<6d6f7264>]
EFLAGS: 00010286
eax: 00000000   ebx: f8a76924   ecx: 07772c7c   edx: 00000000
esi: 00000000   edi: 00000001   ebp: bffffeb8   esp: f7ff7e90
ds: 0018   es: 0018   ss: 0018
Process linuxrc (pid: 8, stackpage=f7ff7000)
Stack: c011b43d f8a76924 00000001 00000000 f7ff6000 00000000 00000072 c011b742 
       c0272a28 00000001 00000000 c011098d f7ff7eec f7956090 c0240000 c017280c 
       f7ff6000 00000000 c0240000 c025f520 f7ff7ef8 00000286 f7ff7ef8 c01106fe 
Call Trace: [<c011b43d>] [<f8a76924>] [<c011b742>] [<c011098d>] [<c017280c>]
[<c01106fe>] [<c0110630>] 
       [<c013bea9>] [<c013c3fd>] [<c012e285>] [<c0108ebf>] [<fee1dead>] 
Code:  Bad EIP value.

>>EIP; 6d6f7264 Before first symbol   <=====
Trace; c011b43d <notifier_call_chain+1d/34>
Trace; f8a76924 <[cdrom].rodata.start+224/1b3f>
Trace; c011b742 <sys_reboot+da/1c0>
Trace; c011098d <schedule+269/398>
Trace; c017280c <con_put_char+1c/20>
Trace; c01106fe <schedule_timeout+86/a0>
Trace; c0110630 <process_timeout+0/48>
Trace; c013bea9 <do_select+1fd/214>
Trace; c013c3fd <sys_select+521/530>
Trace; c012e285 <sys_write+c1/cc>
Trace; c0108ebf <system_call+33/38>
Trace; fee1dead <END_OF_CODE+6381ab6/????>

Kernel panic: VFS: Unable to mount root fs on 08:41

Comment 14 Bill Nottingham 2001-04-03 19:15:22 UTC
*** Bug 32578 has been marked as a duplicate of this bug. ***

Comment 15 Matt Domsch 2001-04-03 21:52:09 UTC
My mistake, 32578 is *not* a duplicate.  32578 causes an oops on reboot, while 
this one only hangs on reboot.  The oops messages above were incorrectly put 
into this bugzilla.  Sorry for the confusion.


Comment 16 John A. Hull 2001-04-19 21:03:19 UTC
putting append= "reboot=b" in lilo.conf fixes the issue.

Comment 17 Arjan van de Ven 2001-04-19 21:16:46 UTC
I'll mail you a program we can use to detect the exact bios (as this is a bios
problem) this machine has, and then make "reboot=b" the default for this bios.
Please scream if that is unacceptable to you.

Comment 18 John A. Hull 2001-04-20 22:05:21 UTC
Created attachment 15924 [details]
Output of dmidecode for PE 1300

Comment 19 Arjan van de Ven 2001-04-20 22:08:20 UTC
Thanks. This seems to be the second PE1300 model that has the problem...
I'll add both to the workaround list.

Comment 20 Arjan van de Ven 2001-04-26 10:59:35 UTC
Should be fixed as of 2.4.3-2.12.1 (available from the beta-site)


Note You need to log in before you can comment on or make changes to this bug.