Bug 253227 - Installer crashes in kickstart.py script on line1056 when performing a kickstart upgrade
Installer crashes in kickstart.py script on line1056 when performing a kickst...
Status: CLOSED DUPLICATE of bug 241395
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 10:28 EDT by Gunter Woytowitz
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 10:32:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gunter Woytowitz 2007-08-17 10:28:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)

Description of problem:
When performing an kickstart upgrade from a CDROM the install crashses in the kickstart.py script. 




Version-Release number of selected component (if applicable):
anaconda-11.2.0.66-1

How reproducible:
Always


Steps to Reproduce:
1.Boot with this command

boot: linux ks=cdrom:/ks.cfg

2. Using the following ks.cfg file
--------------
upgrade
nfs --server=10.10.52.31 --dir=/export/fc7/ISO
lang en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp
-----------------


Actual Results:
I get the following error

....
 File "/usr/lib/anaconda", line 949, in <module>
   kickstart.setSteps(anaconda)
 File "/usr/lib/anaconda/kickstart.py", line 1056, in setSteps
   upgrade.setSteps(anaconda)
AttributeError: 'bool' object has no attribute 'setSteps'
install exited abnormally [1/1]
....



Expected Results:
Should successfully upgrade!!

Additional info:
If I change the ks.cfg file to be an "install" instead of an "upgrade" with similar settings everything works fine.

Here's a snippet of the kickstart.py code line 949 is the problem.
-------------------------------------------------
945:    interactive = ksdata.interactive.interactive
946:    upgrade = ksdata.upgrade.upgrade
947:
948:    if upgrade:
949:        upgrade.setSteps(anaconda)
950:
951:        # we have no way to specify migrating yet
-----------------------------------------------------

It does appear that the upgrade variable is just a boolean, so I'm not sure how any upgrade would ever work????
Comment 1 Chris Lumens 2007-08-17 10:32:07 EDT

*** This bug has been marked as a duplicate of 241395 ***

Note You need to log in before you can comment on or make changes to this bug.