Bug 253327 - eth0 can send messages, but doesn't receive them
eth0 can send messages, but doesn't receive them
Status: CLOSED DUPLICATE of bug 251754
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 17:08 EDT by Andreas Sikkema
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 15:00:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Sikkema 2007-08-17 17:08:49 EDT
Description of problem:
After kernel update to 2.6.22.1-32.fc6 I can't get the ethernet interface on my
Dell Inspiron 5150 to work. The wireless interface works without problems when I
enable it.

The problem is first noticed when using DHCP, when tracing on the DHCP server
(using tcpdump) and the laptop (using wireshark) I can see the laptop sending a
DHCP REQUEST message, and the server receiving it and replying with an OFFER,
the OFFER is never received by the laptop, wireshark doesn't see the reply at all.

lspci gives the following data on the network interface:
02:01.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
I think the module used for this controller is called b44

Flushing iptables with iptables -F doesn't help.

Version-Release number of selected component (if applicable):
2.6.22.1-32.fc6

How reproducible:
Activating the DHCP configured eth0 interface will fail with a tiemout after 5 tries

Steps to Reproduce:
1. ifdown eth0
2. ifup eth0
  
Actual results:
Timeout on the DHCP requests

Expected results:
Normal DHCP protocol being followed as happened before

Additional info:
Comment 1 Chuck Ebbert 2007-08-20 15:00:40 EDT

*** This bug has been marked as a duplicate of 251754 ***

Note You need to log in before you can comment on or make changes to this bug.