Bug 251754 - Broadcom ethernet fails on 2.6.22-1.32.fc6 kernel update
Broadcom ethernet fails on 2.6.22-1.32.fc6 kernel update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 253327 253378 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 17:07 EDT by Mark Hittinger
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.22.2-42.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 14:59:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from kernel 2.6.22-1.32.fc6 (16.41 KB, application/octet-stream)
2007-08-11 16:42 EDT, Mark Hittinger
no flags Details
dmesg from kernel 2.6.22-2.39.fc6 (16.46 KB, text/plain)
2007-08-11 16:43 EDT, Mark Hittinger
no flags Details
dmesg from kernel 2.6.20-1.2962.fc6 (16.57 KB, text/plain)
2007-08-11 16:44 EDT, Mark Hittinger
no flags Details
lspci -vvv for all 3 kernels tested (6.45 KB, application/octet-stream)
2007-08-11 16:45 EDT, Mark Hittinger
no flags Details

  None (edit)
Description Mark Hittinger 2007-08-10 17:07:43 EDT
Description of problem:

Systems with Broadcom 4401 ethernet chips fail to access hardwired lan.

OK on 2.6.20-1.2962.fc6

Version-Release number of selected component (if applicable):

2.6.22-1.32.fc6 kernel

How reproducible:

Update system with broadcom 4401 ethernet chip and boot.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Aug 10 11:24:54 nlp17 kernel: b44: eth0: transmit timed out, resetting
Aug 10 11:24:55 nlp17 kernel: b44: eth0: Link is down.

ethernet never comes ready

Expected results:


Additional info:
Comment 1 Chuck Ebbert 2007-08-10 17:27:02 EDT
If you can, try a test kernel from:

  http://people.redhat.com/cebbert/kernels/FC6/

Otherwise, just try adding "pci=nomsi,nommconf" to the kernel boot parameters.
Comment 2 Mark Hittinger 2007-08-10 17:57:55 EDT
the test kernel (2.6.22.2-39.fc6) also fails in the same way.  the device is
seen/probed but I suspect it isn't being initialized correctly.

pci=nomsi,nommconf options don't have an effect on this.

With the 2962 kernel on BCM4401 systems during a boot with 8 or so NFS mounts
the first mount attempt always fails but the remaining ones succeed.  This
might be related - after some accesses the device begins to respond properly
under 2962. 
Comment 3 Chuck Ebbert 2007-08-10 18:12:11 EDT
Please post the boot messages (file /var/log/dmesg) after booting the latest kernel.
Comment 4 Mark Hittinger 2007-08-11 16:42:58 EDT
Created attachment 161119 [details]
dmesg from kernel 2.6.22-1.32.fc6
Comment 5 Mark Hittinger 2007-08-11 16:43:46 EDT
Created attachment 161120 [details]
dmesg from kernel 2.6.22-2.39.fc6
Comment 6 Mark Hittinger 2007-08-11 16:44:41 EDT
Created attachment 161121 [details]
dmesg from kernel 2.6.20-1.2962.fc6
Comment 7 Mark Hittinger 2007-08-11 16:45:24 EDT
Created attachment 161122 [details]
lspci -vvv for all 3 kernels tested
Comment 8 Chuck Ebbert 2007-08-13 15:52:49 EDT
Try blacklisting the ssb driver by adding this line to
/etc/modprobe.d/blacklist:

blacklist ssb
Comment 9 Mark Hittinger 2007-08-14 11:43:43 EDT
Oh I like that idea - that another device probe may have messed it up.

Unfortunately blacklist ssb doesn't help.  The behavior was the same.

The dmesg still talked about ssb - so maybe the blacklisting didn't work.
Is there another way to disable the ssb driver short of recompiling a kernel
without it?
Comment 10 Chuck Ebbert 2007-08-14 11:51:26 EDT
(In reply to comment #9)
> The dmesg still talked about ssb - so maybe the blacklisting didn't work.
> Is there another way to disable the ssb driver short of recompiling a kernel
> without it?
> 

make a backup copy of it, then delete it from wherever it lives in
/lib/modules/<kernelversion>/
Comment 11 Mark Hittinger 2007-08-15 10:42:28 EDT
Removing the ssb driver causes unknown ssb_* symbols when b44.ko tries to load.

Maybe thats why blacklisting didn't work.
Comment 12 John W. Linville 2007-08-15 11:25:11 EDT
Looks like the b44 bits of git-wireless-dev.patch in those FC6 kernels are 
broken.  Since they aren't needed, I removed them.

I'm not sure what the process is nowadays to get FC6 stuff out to the 
public -- Chuck, can you make sure 2.6.22.2-42.fc6 gets made available?
Comment 13 Mark Hittinger 2007-08-20 14:27:44 EDT
The 2.6.22.2-42.fc6 kernel resolves the issue with the bcm4401 
chip.  The hardwired network is accessible again.

Thanks!
Comment 14 Chuck Ebbert 2007-08-20 15:00:46 EDT
*** Bug 253327 has been marked as a duplicate of this bug. ***
Comment 15 Chuck Ebbert 2007-08-20 15:13:05 EDT
*** Bug 253378 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.