Bug 253360 - Could not touch the pop up window of stardict
Summary: Could not touch the pop up window of stardict
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: stardict   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Hu Zheng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 253859 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-18 08:42 UTC by ZipanChen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 06:33:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the video of reproducible (2.12 MB, application/ogg)
2007-08-18 08:42 UTC, ZipanChen
no flags Details

Description ZipanChen 2007-08-18 08:42:12 UTC
Description of problem:
I can't click the button of the pop up window of stardict.

Version-Release number of selected component (if applicable):
stardict-3.0.0-1.fc8

How reproducible:
See the attachment for more.

Steps to Reproduce:
1. Install f8t1
2. yum install stardict
3. Run

Comment 1 ZipanChen 2007-08-18 08:42:14 UTC
Created attachment 161789 [details]
the video of reproducible

Comment 2 Hu Zheng 2007-08-20 08:21:07 UTC
Can you download the source package, compile it after these modification and
test it?

floatwin.cpp
 gboolean FloatWin::vMotionNotifyCallback (GtkWidget * widget, GdkEventMotion *
event , FloatWin *oFloatWin)
 {
-       if (event->window == oFloatWin->FloatWindow->window || (event->state &
GDK_BUTTON1_MASK))
-       {
+       if (event->state & GDK_BUTTON1_MASK) {

If this fixed this problem, I will update it as add this patch. Thank you!

Comment 3 ZipanChen 2007-08-20 12:53:14 UTC
After change the source code, it works!

I need to install some packages for the "make" command, they are
"libSM-devel"
"libICE-devel"
"libgnomeui-devel"
"gnome-vfs2-devel"
I think they're missing from ./configure

Thanks again for fixed this problem.

Comment 4 Hu Zheng 2007-08-23 02:07:21 UTC
*** Bug 253859 has been marked as a duplicate of this bug. ***

Comment 5 Hu Zheng 2007-08-23 03:47:20 UTC
Should fixed now, you can try the 3.0.0-3 version.

* Thu Aug 23 2007 Hu Zheng <zhu@redhat.com> - 3.0.0-3
- Add floatwin and espeak patch.


Note You need to log in before you can comment on or make changes to this bug.