Bug 253370 - unhandled exception in pirut
unhandled exception in pirut
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-18 08:39 EDT by xunilarodef
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 14:02:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The crash dump traceback produced by pirut. (557 bytes, text/plain)
2007-08-18 08:39 EDT, xunilarodef
no flags Details
The crash dump traceback produced by pirut when Downloading. (2.23 KB, text/plain)
2007-08-18 18:20 EDT, xunilarodef
no flags Details

  None (edit)
Description xunilarodef 2007-08-18 08:39:51 EDT
Description of problem:
  Pirut encountered an unhandled exception after prompting for a reboot.

Version-Release number of selected component (if applicable):
  pirut.noarch.1.3.10-1.fc8

How reproducible:
  One out of two times?

Steps to Reproduce:
1. The yum-updatesd service daemon discovers updates are available. 
2. Select Apply.
3. After "Downloading software", "Updating software", etc. phases
   complete, since a kernel update was included, the dialog titled 
   "Reboot recommended" displays:
      Due to the updates installed, it is recommended
      that you reboot your system.  You can either reboot 
      now or choose to do so at a later time.
      Reboot later    Reboot now
4. Select "Reboot now"

Actual results:
A dialog titled "Exception Occurred" displays:
   An unhandled exception has occurred.  This is most likely
   a bug.  Please save the crash dump and file a detailed bug
   report against pirut ....

Expected results:
Just quietly reboot without additional manual intervention.

Additional info:
  One of the packages being updated in this transaction was pirut, from:
  pirut.noarch.1.3.10-1.fc8
to:
  pirut.noarch 1.3.11-1.fc8

  This happened during a second run of pirut.  The first run was
processing 169 package updates, and in its "Updating software"
phase it progressed to "Updating wireless tools" ... and then
made no further progress.  No new activity was recorded in 
/etc/log/yum.log for more than an hour, while neither the pup nor 
puplet processes accumulated any more CPU time (per System Monitor).
So resorted to System, Shutdown, Restart, and pirut proclaims
87 package updates are available, and after processing them (using
the previously downloaded package data), the exception noted above
happened.
Comment 1 xunilarodef 2007-08-18 08:39:51 EDT
Created attachment 161794 [details]
The crash dump traceback produced by pirut.
Comment 2 xunilarodef 2007-08-18 18:17:28 EDT
  This may be an unrelated failure, will move to a separate bug if so
advised.  Later, upon selection of one additional package to install,
select Apply, and very quickly in the "Downloading packages" phase
rewarded with another unhandled exception.
Comment 3 xunilarodef 2007-08-18 18:20:20 EDT
Created attachment 161809 [details]
The crash dump traceback produced by pirut when Downloading.
Comment 4 Jeremy Katz 2007-08-20 14:02:04 EDT
The first is a dupe of bug 252328; the second, I just fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.