Bug 253378 - fc6 kernel 2.6.22 breaks bcm4401 network driver
fc6 kernel 2.6.22 breaks bcm4401 network driver
Status: CLOSED DUPLICATE of bug 251754
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-18 11:15 EDT by David Kahn
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 15:12:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kahn 2007-08-18 11:15:06 EDT
Description of problem:

Network doesn't work when upgraded to 2.6.22.1-32 kernel with Broadcom bcm4401
motherboard network device on Abit IS-10 and Dell Dimension 2400

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. yum update
2. reboot
3.
  
Actual results:

onboard bmc4401 doesn't work (network is physically
connected to the switch, but unable to ping in
or out with kernel 2.6.22.1 Works fine with 2.6.20

Expected results:

The network should work :)

Additional info:

There's a huge thread about config option changes for onboard vs card-based
bcm44xx (b44.c) during 2.6.22-rc2 development. Not sure what (if any) the
outcome was, but for me, my bmc4401 based machines all broke when I upgraded to
fc6 kernel 2.6.22.1. There's a 2.6.22.2 out, and it downloaded, but the release
notes for 2.6.22.2 don't say anything about fixes for bcm440x
Comment 1 David Kahn 2007-08-18 11:17:10 EDT
Sorry, anywhere I typed bmc4401, I meant Broadcom BCM4401

-David
Comment 2 David Kahn 2007-08-18 11:21:30 EDT
This is the thread I referred to:

http://www.ussg.iu.edu/hypermail/linux/kernel/0705.3/0304.html

Comment 3 Chuck Ebbert 2007-08-20 15:12:49 EDT
Fixed.

*** This bug has been marked as a duplicate of 251754 ***

Note You need to log in before you can comment on or make changes to this bug.