Bug 253464 - Traceback when adding a fifth share in system-config-samba
Traceback when adding a fifth share in system-config-samba
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 256961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-19 21:20 EDT by Stewart Adam
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.52-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:24:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2007-08-19 21:20:32 EDT
Description of problem:
It seems that no matter what the path or input is, when adding a fifth share an
error occurs:

Traceback (most recent call last):
  File "/usr/share/system-config-samba/shareWindow.py", line 436, in
onOkButtonClicked
    token = self.samba_data.createToken("", last_section)
  File "/usr/share/system-config-samba/sambaParser.py", line 228, in createToken
    if line[-1] == '\n':
IndexError: string index out of range


Version-Release number of selected component (if applicable):
system-config-samba-1.2.47-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Add four shares
2. Try to add a fifth
3.
  
Actual results:
The traceback above is shown in the terminal and the new entry appears on the
gtk.Treeview, although the 'New' dialog does not close and upon restarting
system-config-samba, the new entry is nowhere to be found.

Expected results:
The entry adds itself to the configuration file

Additional info:
Running `testparm` shows that with the 4 sections it's a valid configuration file
Comment 1 Nils Philippsen 2007-08-27 04:26:38 EDT
I've fixed this in the upstream repository.
Comment 2 Nils Philippsen 2007-08-28 04:58:34 EDT
This should be fixed in system-config-samba-1.2.48 which is being built right
now for Rawhide.
Comment 3 Nils Philippsen 2007-09-05 04:18:08 EDT
*** Bug 256961 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2007-09-07 13:16:46 EDT
system-config-samba-1.2.50-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-09-10 12:52:22 EDT
system-config-samba-1.2.51-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-09-17 23:24:12 EDT
system-config-samba-1.2.52-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.