Bug 256961 - s-c-samba does not save config
s-c-samba does not save config
Status: CLOSED DUPLICATE of bug 253464
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 12:08 EDT by Thomas Canniot
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 04:18:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Canniot 2007-08-27 12:08:43 EDT
Description of problem:
Samba does not save shared folders

Version-Release number of selected component (if applicable):
samba-common-3.0.25b-2.fc7
samba-3.0.25b-2.fc7
samba-client-3.0.25b-2.fc7
system-config-samba-1.2.47-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Open s-c-samba
2. Create a new shared folder
3. Browse to point to the shared file
4. Don't enter any description, check the 2 boxes visible and writable
5. In the access tab, allow everyone (lower button)
6. Validate
-> the folder is adding on the back window, but the window to add a shared
folder does not close it self.

7. Try to delete your shared folder. It does not work and the following lines
appear.

Traceback (most recent call last):
  File "/usr/share/system-config-samba/shareWindow.py", line 436, in
onOkButtonClicked
    token = self.samba_data.createToken("", last_section)
  File "/usr/share/system-config-samba/sambaParser.py", line 228, in createToken
    if line[-1] == '\n':
IndexError: string index out of range
Traceback (most recent call last):
  File "/usr/share/system-config-samba/mainWindow.py", line 341, in
onDeleteButtonClicked
    section.delete ()
AttributeError: 'NoneType' object has no attribute 'delete'
Traceback (most recent call last):
  File "/usr/share/system-config-samba/mainWindow.py", line 341, in
onDeleteButtonClicked
    section.delete ()
AttributeError: 'NoneType' object has no attribute 'delete'
Traceback (most recent call last):
  File "/usr/share/system-config-samba/mainWindow.py", line 341, in
onDeleteButtonClicked
    section.delete ()
AttributeError: 'NoneType' object has no attribute 'delete'

  

I don't think it may be relevant to give you my smb.conf file, as I just
installed s-c-samba and used it without having tried anything before. I tested
it at work, on a very fresh install of FC7, and it does not work either.

Thanks.
Comment 1 Carlos Bulleri 2007-09-05 01:18:28 EDT
cbulleri@yahoo.com

I have exactlly the same situation. Please respond with a solution. Thanks

fresh fedora 7 install . 

Comment 2 Nils Philippsen 2007-09-05 04:18:07 EDT
Upon closer inspection, this really is a duplicate of bug #253464.

*** This bug has been marked as a duplicate of 253464 ***

Note You need to log in before you can comment on or make changes to this bug.