Bug 25357 - php-3.0.18-1.6.x still breaks multipart uploads
php-3.0.18-1.6.x still breaks multipart uploads
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 25356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 18:42 EST by Adam Thompson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-21 17:19:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Thompson 2001-01-30 18:42:34 EST
after installing php-3.0.18-1.6.x from errata SRPM, multipart uploads no 
longer crash httpd, BUT all uploaded files are prepended with a CR+LF pair.

Additionally, OOHFORMS (from PHPLIB-7.2) fails to operate correctly when 
used in multipart-encoded forms.  We assume it's the same problem, but 
haven't delved deeply into it.

Also, horde-1.2.3-1 and imp-2.2.3-1 together break on the Compose mail 
window - another multipart-encoded form.

It would seem that the cure is almost as bad as the disease...
Comment 1 Bill Nottingham 2001-01-31 12:38:29 EST
*** Bug 25356 has been marked as a duplicate of this bug. ***
Comment 2 Nalin Dahyabhai 2001-02-02 01:12:09 EST
Yes, there's something amiss in how the form parsing code handles content-type
headers.  There should be a 3.0.18 fix candidate in
http://people.redhat.com/nalin/test/ which should solve this problem, and I'm
asking people who've had problems with the previous set to give them a try. 
Please have a look and either follow up to this bug ID, or to bug #24933, which
is the relevant bug for 4.0.4pl1.

Thanks!
Comment 3 Adam Thompson 2001-02-06 23:38:20 EST
Tried the test RPMs.

It fixes trivial cases, such as sending messages through IMP without 
attachments, but anything with an actual file upload still breaks, with a 
message like this:
==========
Warning: File Upload Mime headers garbled [ 
in /home/httpd/html/horde/imp/compose.php3 on line 1

Warning: Cannot add more header information - the header was already sent 
(header information may be added only before any output is generated from the 
script - check for text or whitespace outside PHP tags, or calls to functions 
that output text) in session.inc on line 448
==========

Of course, the second error message has nothing to do with this bug, it's just 
a side-effect.

Again: the test RPMs fix cases where there is no actual file being uploaded, 
but still appear to break when uploading a file.

Comment 4 Adam Thompson 2003-08-21 17:19:29 EDT
This is ridiculously old... and I confirmed the problem with pristine PHP 
source on a Solaris box anyway, so it's not a RedHat problem.
(It's fixed in current PHP versions.)

Note You need to log in before you can comment on or make changes to this bug.