Bug 253616 - Install freeze at "Write protecting the kernel read-only data"
Install freeze at "Write protecting the kernel read-only data"
Status: CLOSED DUPLICATE of bug 348931
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-20 17:32 EDT by Mike McGrath
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 13:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike McGrath 2007-08-20 17:32:16 EDT
Description of problem:

When attempting to run:

virt-install -p -n publictest3 -r 1024 -f /dev/xenGuests/publictest3
--nographics -l  nfs:server:/path/  -x 'ip=10.0.0.1 netmask=255.255.255.0
gateway=10.0.0.2 dns=10.0.0.3 ks=http://myksserver/ks'

It loads up and freezes at:

XENBUS: Device with no driver: device/vbd/51712
XENBUS: Device with no driver: device/vif/0
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Freeing unused kernel memory: 200k freed
Write protecting the kernel read-only data: 981k




Presently I'm trying to install rawhide in a xen guest on an x86_64 FC6 box:
xen-3.0.3-9.fc6
python-virtinst-0.98.0-1.fc6
2.6.19-1.2911.6.4.fc6xen

I'm not sure if this is a xen issue or not.  I'm actually seeing the same
behavior when trying to install an F7 instance.  I'm seeing it on multiple machines.
Comment 1 Mike McGrath 2007-08-21 15:28:49 EDT
appending -x "console=tty0 console=xvc0" fixes this issue.  Riel says its a 
bug in the kernel that shipped with F7 but it still exists in rawhide it 
seems.
Comment 2 Mike McGrath 2007-08-29 23:16:13 EDT
Is this being fixed in rawhide?
Comment 3 Eduardo Habkost 2007-10-23 13:25:54 EDT
I have reported this as bug #348931.

Marking this as duplicate as the other ticket was referenced on changelog and 
contains the patch that was included for F-8.

*** This bug has been marked as a duplicate of 348931 ***

Note You need to log in before you can comment on or make changes to this bug.