Bug 348931 - virt-install --nographics --paravirt is broken
virt-install --nographics --paravirt is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Eduardo Habkost
Fedora Extras Quality Assurance
:
: 253616 330911 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-23 11:44 EDT by Eduardo Habkost
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.6.20-2943.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 20:46:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the problem (1.32 KB, patch)
2007-10-23 11:44 EDT, Eduardo Habkost
no flags Details | Diff

  None (edit)
Description Eduardo Habkost 2007-10-23 11:44:22 EDT
Description of problem:

virt-install --nographics --paravirt is broken, currently, on Fedora 7 and 
Rawhide.

As reported by Markus Armbruster:

"Dan pointed me to the fact that virt-install --nographics --paravirt
doesn't work in F-7 and Rawhide.  I checked, and found that we lost
our hack to make sure console output goes somewhere sane when PVFB is
off.  The appended patch applies both to kernel-xen-2.6/F-7 and devel.
I built a devel kernel, and it fixes virt-install."


The patch is attached to this bug report.



Steps to Reproduce:
virt-install --nographics --paravirt --file /var/lib/xen/images/text.img --file-size 
5 --name text --ram 500 --location nfs:<path to Fedora 
mirror>/redhat/released/F-7/GOLD/Fedora/x86_64/os
  
Actual results:
install kernel boots, prints a few messages, then i/o stops


Expected results:
proceeds to text install
Comment 1 Eduardo Habkost 2007-10-23 11:44:22 EDT
Created attachment 235151 [details]
Patch to fix the problem
Comment 2 Eduardo Habkost 2007-10-23 13:25:55 EDT
*** Bug 253616 has been marked as a duplicate of this bug. ***
Comment 3 Eduardo Habkost 2007-10-23 13:26:23 EDT
*** Bug 330911 has been marked as a duplicate of this bug. ***
Comment 4 Jesse Keating 2007-10-25 09:01:55 EDT
kernel-xen-2.6-2.6.21-2950.fc8 was built with this fix, and released to rawhide
(F8).
Comment 5 Fedora Update System 2007-11-09 18:38:33 EST
kernel-xen-2.6-2.6.20-2943.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel-xen-2.6'
Comment 6 Fedora Update System 2007-11-28 20:46:03 EST
kernel-xen-2.6-2.6.20-2943.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.