Bug 253730 - evolution message refresh loses focus
evolution message refresh loses focus
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
: 439432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-21 11:09 EDT by Adam Jackson
Modified: 2008-04-30 08:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 12:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 467892 None None None Never

  None (edit)
Description Adam Jackson 2007-08-21 11:09:36 EDT
Description of problem:

From IRC:

<@ajax> mbarnes: i have evo set to do ~30 minute checks for new messages, plus
automatic message filtering, and the folder view shows only unread messages. 
when it checks for new messages, and some new ones get filtered into the folder
i'm currently in, the message i'm currently on gets marked as "read", and
therefore disappears.

Even when new messages don't filter into the current mailbox, the view panes
still flash.  These might be separate bugs, or might not.

Version-Release number of selected component (if applicable):

evolution-2.10.0-2.fc7
Comment 1 Matthew Barnes 2007-08-21 11:36:35 EDT
I think the flashing is a separate bug.  I've seen it reported elsewhere and can
readily reproduce it myself.  It seems to only happen with longish messages.  I
think GtkHTML is using a refresh timer while it renders the HTML, but it's
erasing itself and then redrawing the whole thing with each refresh.  Hence the
flashing.

For REALLY long messages you'll notice the flashing gets slower as more of the
message is rendered, I guess because it takes longer to draw.

Anyway, for this bug I'll focus on the message list behavior you described.
Comment 2 Matthew Barnes 2007-10-31 09:33:42 EDT

*** This bug has been marked as a duplicate of 247332 ***
Comment 3 Adam Jackson 2008-02-13 16:09:09 EST
Un-duping.  247332 is about the flashy refresh, this is for the message list thing.
Comment 4 Matthew Barnes 2008-02-13 16:36:53 EST
Oh, whoops, sorry.  I don't even remember closing this one.

CC'ing Milan.
Comment 5 Milan Crha 2008-03-06 10:19:05 EST
Do you really think this is a bug? The updating folder thing. Evo just every ~30
minutes call update on each folder and then refreshes view. Which is probably
correct, right? I remember I did a patch, included definitely in 2.21.91, which
ensures there always selected any message, when the actual "disappear" (either
deleted, filtered out or anything else). It _tries_ to find the "nearest"
message from the old one.

Is this enough for this issue?
Comment 6 Matthew Barnes 2008-03-06 18:49:15 EST
I think Adam's issue is the fact that a selected message in a folder gets marked
as read when new messages get moved into that folder via filters.  If your view
is only showing unread messages, the message may disappear on you while you're
still reading it.
Comment 7 Milan Crha 2008-03-31 09:12:07 EDT
*** Bug 439432 has been marked as a duplicate of this bug. ***
Comment 8 Milan Crha 2008-03-31 09:29:56 EDT
Upstream bug for this is 
http://bugzilla.gnome.org/show_bug.cgi?id=467892

Can we track it there? The problem is much complicated than it can seem to be.
Comment 9 Milan Crha 2008-03-31 12:04:10 EDT
Hmm, OK, I attached a proposed patch to upstream bug, we will see what they say.
I'm closing this as 'upstream'.
Comment 10 Matthew Saltzman 2008-04-30 07:56:33 EDT
A patch for this has been committed upstream.  Is it possible to port, or at
least make sure it is updated for F9?
Comment 11 Milan Crha 2008-04-30 08:05:59 EDT
Sure, it's committed to stable branch too, which means next update will include
it. I heard they plan next release on this Friday, so after that we will update
our package too.

Note You need to log in before you can comment on or make changes to this bug.