Bug 439432 - Updating unread messages in messge window loses the message you are reading
Updating unread messages in messge window loses the message you are reading
Status: CLOSED DUPLICATE of bug 253730
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-28 13:46 EDT by Matthew Saltzman
Modified: 2008-03-31 09:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-31 09:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2008-03-28 13:46:53 EDT
Description of problem:
If you select "show unread messages", and if the list of unread messages is
updated, the message you are currently reading is removed from the message
window and the preview window.  That's annoying if you haven't finished reading
it or you need to do something with it, such as move or reply.  Then you need to
switch to "show all messages" to get it back.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Select "Show unread messages".
2. Read a message.  Status changes to read after a second or so.
3. Wait for a new message to arrive.
Actual results:
All messages marked read disappear from view, including the one you are reading.

Expected results:
All messages marked read disappear from view, except the one you are reading.

Additional info:
Comment 1 Milan Crha 2008-03-28 13:56:55 EDT
Is there any difference between pressing F5 and timed update? I mean, there is
almost none for the code, but for the user it can be. One can expect the F5 will
not take care of actually selected (or rather focused) message. Am I right?
Comment 2 Matthew Saltzman 2008-03-28 14:32:20 EDT
F5 does not remove any messages marked read from the window.

Mark some messages unread.  Select "show unread messages".  Mark all messaged
read.  Press F5.  No change in display.

Same behavior if you click send/receive.

Now the case I saw occurred when I was reading a folder and filters caused an
arriving message to be moved to that folder.

What I don't know (I can't think of a good way to simulate it, don't have the
patience to wait around) is whether old messages are cleared in the case where
pressing F5 causes new messages to appear.  If you have an easy way to simulate
that, I'd be glad to try.  In any case, that might be the interesting execution
path to track.
Comment 3 Milan Crha 2008-03-31 09:12:07 EDT
Right, I see what you mean. I found a bug about this, marking this as a duplicate.

*** This bug has been marked as a duplicate of 253730 ***

Note You need to log in before you can comment on or make changes to this bug.