Bug 253823 - USB/Firewire coldplugging does not work
USB/Firewire coldplugging does not work
Status: CLOSED DUPLICATE of bug 249602
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
: 262441 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 03:45 EDT by Thomas Schweikle
Modified: 2007-12-13 13:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 13:48:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lsusb -v (19.06 KB, text/plain)
2007-09-28 03:51 EDT, Bruno Wolff III
no flags Details
dmidecode (13.60 KB, text/plain)
2007-09-28 03:52 EDT, Bruno Wolff III
no flags Details
lspci -vvxxx (25.04 KB, text/plain)
2007-09-28 03:54 EDT, Bruno Wolff III
no flags Details
udevtrigger output (/sbin/udevtrigger --verbose) (10.62 KB, text/plain)
2007-10-16 06:29 EDT, Thomas Schweikle
no flags Details

  None (edit)
Description Thomas Schweikle 2007-08-22 03:45:02 EDT
Description of problem:
If an USB or Firewire storage device is 
already plugged, it will not be represented in 
"/dev". The device has to be unplugged, the 
replugged to make it show up in "/dev".


Version-Release number of selected component 
(if applicable):
libusb-0.1.12-7.fc7
usbutils-0.71-2.1
udev-113-11.fc7
libusb-devel-0.1.12-7.fc7


How reproducible:
always

Steps to Reproduce:
1. Turn off your PC
2. Plug in a usb or firewire storage device
3. Turn on your PC again
4. The device will not show up in /dev.
5. unplug the device, then replug it.
6. The device will now show up in /dev.
  
Actual results:
The storage device does not show up in /dev.

Expected results:
The device should show up in /dev.

Additional info:
Since there is a workaround this is not fatal, 
but annoying.
Comment 1 Harald Hoyer 2007-08-22 04:08:44 EDT
like what devices? all usb/firewire or s.th. special?
Comment 2 Thomas Schweikle 2007-08-22 10:57:40 EDT
Storage devices like external USB, Firewire or eSATA devices. These may be 
Memory-Sticks or external HD. Even cameras attached as "storage device".

I could test with different Hardware:
- Laptop (JVC PC/MP-XP7210)
- Laptop (Acer 3010)
- Desktop (Gigabyte Mainboard P4)

and different USB, Firewire, and eSATA devices:
- Onnto USB-2.0/1394a 2.5" Combo HDD
- Onnto USB-2.0/1394b/eSATA 3.5" Combo HDD
- FireView USB-1.1/1394a 2.5" Combo HDD
- Dell Memory Stick
- CM-Stick 512M
- Lumix FX10
- Canon 750

All the same: plugged while F7 running all OK, plugged then starting PC I have 
to unplug, then plug again to make them accessible. It does not matter if there 
is a hub in between or not.

Hub, mice, keyboards are recognized hot or cold plugged. But not storage 
devices.
Comment 3 Harald Hoyer 2007-08-22 11:03:13 EDT
do you mean, that there is no device node in /dev, or do you just see no icons
on your desktop?
Comment 4 Thomas Schweikle 2007-08-22 14:26:23 EDT
There is no device node. The icons on the desktop are not created --- but how 
could they created if the device node is missing?

The device nodes are created if I replug them: unplug, the plug, device nodes 
are now created and partitions are mounted.

This is only if the device is already plugged (and powered on --- for the 
external HD since they need more power than an USB-, Firewire-, or eSATA-Port 
is capable to deliver) at the time the PC is turned on. Plugging while Fedora 7 
is running does always work as expected.
Comment 5 Harald Hoyer 2007-08-23 03:00:09 EDT
Hmm, works for me with my memory stick... (fully updated F-7)

$ ls -l /dev/disk/by-id/usb*

$ ll /dev/disk/by-id/usb*
lrwxrwxrwx 1 root root  9 23. Aug 08:57
/dev/disk/by-id/usb-Multi_Flash_Reader_058F091111B-0:0 -> ../../sdc
lrwxrwxrwx 1 root root 10 23. Aug 08:57
/dev/disk/by-id/usb-Multi_Flash_Reader_058F091111B-0:0-part1 -> ../../sdc1
lrwxrwxrwx 1 root root  9 23. Aug 08:57
/dev/disk/by-id/usb-Samsung_Mighty_Drive_076B18959160-0:0 -> ../../sdd
lrwxrwxrwx 1 root root 10 23. Aug 08:57
/dev/disk/by-id/usb-Samsung_Mighty_Drive_076B18959160-0:0-part1 -> ../../sdd1
lrwxrwxrwx 1 root root 10 23. Aug 08:57
/dev/disk/by-id/usb-Samsung_Mighty_Drive_076B18959160-0:0-part2 -> ../../sdd2


You may turn on logging for udev.
/etc/udev/udev.conf:
udev_log="debug"

Then watch for the udev messages in /var/log/messages, and attach them here.
Comment 6 Thomas Schweikle 2007-08-23 08:30:56 EDT
OK. Again: the devices in question do have to be plugged in at the time you are 
turning on your computer. After Fedora 7 is up:

# ll /dev/disk/by-path
insgesamt 0
lrwxrwxrwx 1 root root  9 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0 -> ../../hda
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part1 -> ../../
hda1
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part2 -> ../../
hda2
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part3 -> ../../
hda3
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part4 -> ../../
hda4
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part5 -> ../../
hda5
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part6 -> ../../
hda6
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part7 -> ../../
hda7
lrwxrwxrwx 1 root root  9 23. Aug 13:40 pci-0000:00:1f.1-ide-1:0 -> ../../hdc
lrwxrwxrwx 1 root root  9 23. Aug 13:40 pci-0000:02:01.0-scsi-0:0:0:0 -> ../../
sda

There are attached:
ide: one pATA HD  /dev/hda
ide: CDROM        /dev/hdc
3ware: one RAID1  /dev/sda
Dell Memory Stick (no device node)
Onnto external HD (no device node)

This is _after_ turning on the PC _with_ devices _attached_!

Now lets unplug them.
Replug them.

And again:
root@tarkil ~ # ll /dev/disk/by-path
insgesamt 0
lrwxrwxrwx 1 root root  9 23. Aug 13:55 pci-0000:00:1d.2-usb-0:1.1:1.0-scsi-
0:0:0:0 -> ../../sdc
lrwxrwxrwx 1 root root 10 23. Aug 13:55 pci-0000:00:1d.2-usb-0:1.1:1.0-scsi-
0:0:0:0-part1 -> ../../sdc1
lrwxrwxrwx 1 root root  9 23. Aug 13:55 pci-0000:00:1d.7-usb-0:3:1.0-scsi-
0:0:0:0 -> ../../sdb
lrwxrwxrwx 1 root root 10 23. Aug 13:55 pci-0000:00:1d.7-usb-0:3:1.0-scsi-
0:0:0:0-part1 -> ../../sdb1
lrwxrwxrwx 1 root root 10 23. Aug 13:55 pci-0000:00:1d.7-usb-0:3:1.0-scsi-
0:0:0:0-part5 -> ../../sdb5
lrwxrwxrwx 1 root root 10 23. Aug 13:55 pci-0000:00:1d.7-usb-0:3:1.0-scsi-
0:0:0:0-part6 -> ../../sdb6
lrwxrwxrwx 1 root root  9 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0 -> ../../hda
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part1 -> ../../
hda1
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part2 -> ../../
hda2
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part3 -> ../../
hda3
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part4 -> ../../
hda4
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part5 -> ../../
hda5
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part6 -> ../../
hda6
lrwxrwxrwx 1 root root 10 23. Aug 13:40 pci-0000:00:1f.1-ide-0:0-part7 -> ../../
hda7
lrwxrwxrwx 1 root root  9 23. Aug 13:40 pci-0000:00:1f.1-ide-1:0 -> ../../hdc
lrwxrwxrwx 1 root root  9 23. Aug 13:40 pci-0000:02:01.0-scsi-0:0:0:0 -> ../../
sda

Now the devices have device nodes created:
ide: one pATA HD  /dev/hda
ide: CDROM        /dev/hdc
3ware: one RAID1  /dev/sda
Dell Memory Stick /dev/sdc
Onnto external HD /dev/sdb

I have to unplug and replug at least one device to have udev notice a change 
and create all device nodes for all devices not found during boot.

dmesg shows udev getting an event _after_ replugging one device:
usb 3-1.1: new full speed USB device using uhci_hcd and address 4
usb 3-1.1: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi2 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
scsi 1:0:0:0: Direct-Access     SAMSUNG  MP0804H               PQ: 0 ANSI: 0
sd 1:0:0:0: [sdb] 156368016 512-byte hardware sectors (80060 MB)
sd 1:0:0:0: [sdb] Write Protect is off
sd 1:0:0:0: [sdb] Mode Sense: 33 00 00 00
sd 1:0:0:0: [sdb] Assuming drive cache: write through
sd 1:0:0:0: [sdb] 156368016 512-byte hardware sectors (80060 MB)
scsi 2:0:0:0: Direct-Access     LEXAR    DIGITAL FILM     /W1. PQ: 0 ANSI: 2
sd 1:0:0:0: [sdb] Write Protect is off
sd 1:0:0:0: [sdb] Mode Sense: 33 00 00 00
sd 1:0:0:0: [sdb] Assuming drive cache: write through
 sdb:<5>sd 2:0:0:0: [sdc] 31232 512-byte hardware sectors (16 MB)
sd 2:0:0:0: [sdc] Write Protect is off
sd 2:0:0:0: [sdc] Mode Sense: 0d 00 00 00
sd 2:0:0:0: [sdc] Assuming drive cache: write through
sd 2:0:0:0: [sdc] 31232 512-byte hardware sectors (16 MB)
sd 2:0:0:0: [sdc] Write Protect is off
sd 2:0:0:0: [sdc] Mode Sense: 0d 00 00 00
sd 2:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc1
sd 2:0:0:0: [sdc] Attached SCSI removable disk
sd 2:0:0:0: Attached scsi generic sg1 type 0
usb-storage: device scan complete
 sdb1 < sdb5 sdb6 >
sd 1:0:0:0: [sdb] Attached SCSI disk
sd 1:0:0:0: Attached scsi generic sg2 type 0
usb-storage: device scan complete
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sdb6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.

udevd does not get that event if the devices are already plugged and powered on 
at booting time (but that is a bit difficult to show since dmesg does not keep 
enough lines to look at what udevd did when the system is completely up (with 
X11).
Comment 7 Harald Hoyer 2007-08-23 09:04:25 EDT
reassigning the bug (maybe temporarily) to kernel, to ask, wether this is a know
problem, and probably caused by the kernel?
Comment 8 Harald Hoyer 2007-08-23 09:06:09 EDT
btw, /var/log/messages should contain all lines.
Comment 9 Harald Hoyer 2007-08-29 06:08:29 EDT
*** Bug 262441 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2007-09-03 10:38:18 EDT
I think this usb_storage not getting autoloaded. Normally this would happen in
the initrd, but since the module is not included there, it is not loaded on startup.
Udev event replay does not trigger the autoloading of it.
Any suggestions?
Same for firewire?
Comment 11 Bruno Wolff III 2007-09-15 08:38:10 EDT
I am still seeing this with kernel 2.6.22.5-76.fc7.
Comment 12 Christopher Brown 2007-09-26 04:54:42 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

Once the computer had booted with the hardware inserted, see if usb_storage has
loaded with:

lsmod | grep -i usb

If not then before re-plugging the devices try:

# modprobe usb-storage

and check whether this then creates the nodes for you. Like Harald I'm afraid I
cannot replicate - my flash memory card is mounted with desktop icon from boot.
However this has been replicated on a variety of hardware which is obviously
troublesome. I wonder if the reporters would be good enough to attach the
following outputs as text/plain:

# lsusb -v (you may need to install usbutils)
# dmidecode (you may need to install this
# lspci -vvxxx

and if they can indicate whether a USB hub is in use or mainboard ports.
Comment 13 Bruno Wolff III 2007-09-28 03:42:37 EDT
[root@bruno ~]# lsmod | grep -i usb
[root@bruno ~]# 

I don't think that nodes get created for ups', so I tried restarting nut before
and after doing the modprobe and it didn't fix things.


[root@bruno ~]# service ups restart
Stopping UPS monitor:                                      [  OK  ]
Stopping upsd:                                             [  OK  ]
Shutting down upsdrvctl: Network UPS Tools - UPS driver controller 2.0.5
Can't open /var/run/nut/newhidups-ups.pid: No such file or directory

Starting upsdrvctl: Network UPS Tools - UPS driver controller 2.0.5
Network UPS Tools: 0.28 USB communication driver 0.28 - core 0.30 (2.0.5)

No matching HID UPS found
Driver failed to start (exit status=1)
                                                           [FAILED]
Starting upsd: Network UPS Tools upsd 2.0.5
Can't connect to UPS [ups] (ups): No such file or directory
                                                           [  OK  ]
Starting UPS monitor (master): Network UPS Tools upsmon 2.0.5
Using power down flag file /etc/killpower

UPS: ups@localhost (master) (power value 1)
                                                           [  OK  ]
[root@bruno ~]# 
Broadcast message from nut (Fri Sep 28 02:36:26 2007):

Communications with UPS ups@localhost lost

Broadcast message from nut (Fri Sep 28 02:36:31 2007):

UPS ups@localhost is unavailable

I'll attach the other requested items separately as they seem to be kind of long.

The UPS is plugged into the motherboard.
Comment 14 Bruno Wolff III 2007-09-28 03:51:20 EDT
Created attachment 209661 [details]
lsusb -v
Comment 15 Bruno Wolff III 2007-09-28 03:52:32 EDT
Created attachment 209681 [details]
dmidecode
Comment 16 Bruno Wolff III 2007-09-28 03:54:27 EDT
Created attachment 209701 [details]
lspci -vvxxx
Comment 17 Bruno Wolff III 2007-09-28 04:13:28 EDT
I forgot to mention I had upgraded to 2.6.22.7-85.fc7 before running the above
tests.
Comment 18 Thomas Schweikle 2007-09-29 04:32:16 EDT
I found the time to do the tests you mentioned. sbp2 is not loaded after bootup:
# lsmod | grep sbp
# 

# lsusb -v
Bus 005 Device 002: ID 05ab:0060 In-System Design USB 2.0 ATA Bridge
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x05ab In-System Design
  idProduct          0x0060 USB 2.0 ATA Bridge
  bcdDevice           11.05
  iManufacturer          73 In-System Design
  iProduct               90 USB Storage Adapter
  iSerial               110 001121114156B3DF
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     2
    iConfiguration          0 
    bmAttributes         0xc0
      Self Powered
    MaxPower               98mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk (Zip)
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0002  1x 2 bytes
        bInterval               9
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  bNumConfigurations      1

Bus 005 Device 001: ID 0000:0000  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         1 Single TT
  bMaxPacketSize0        64
  idVendor           0x0000 
  idProduct          0x0000 
  bcdDevice            2.06
  iManufacturer           3 Linux 2.6.22.9 ehci_hcd
  iProduct                2 EHCI Host Controller
  iSerial                 1 0000:00:1d.7
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0004  1x 4 bytes
        bInterval              12
Hub Descriptor:
  bLength              11
  bDescriptorType      41
  nNbrPorts             8
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
    TT think time 8 FS bits
  bPwrOn2PwrGood       10 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0xc0 0xa6
  PortPwrCtrlMask    0xf1  0xb7 
 Hub Port Status:
   Port 1: 0000.0100 power
   Port 2: 0000.0100 power
   Port 3: 0000.0100 power
   Port 4: 0000.0503 highspeed power enable connect
   Port 5: 0000.0100 power
   Port 6: 0000.0100 power
   Port 7: 0000.0100 power
   Port 8: 0000.0100 power

Bus 004 Device 001: ID 0000:0000  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         0 Full speed (or root) hub
  bMaxPacketSize0        64
  idVendor           0x0000 
  idProduct          0x0000 
  bcdDevice            2.06
  iManufacturer           3 Linux 2.6.22.9 uhci_hcd
  iProduct                2 UHCI Host Controller
  iSerial                 1 0000:00:1d.3
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0002  1x 2 bytes
        bInterval             255
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             2
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
  bPwrOn2PwrGood        1 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0xc0
  PortPwrCtrlMask    0xa6 
 Hub Port Status:
   Port 1: 0000.0100 power
   Port 2: 0000.0100 power

Bus 003 Device 002: ID 0451:1446 Texas Instruments, Inc. TUSB2040/2070 Hub
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         0 Full speed (or root) hub
  bMaxPacketSize0         8
  idVendor           0x0451 Texas Instruments, Inc.
  idProduct          0x1446 TUSB2040/2070 Hub
  bcdDevice            1.10
  iManufacturer           0 
  iProduct                0 
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           34
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      UNRECOGNIZED:  09 29 04 09 00 32 64 00 1e
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0001  1x 1 bytes
        bInterval             255
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             4
  wHubCharacteristic 0x0009
    Per-port power switching
    Per-port overcurrent protection
  bPwrOn2PwrGood       50 * 2 milli seconds
  bHubContrCurrent    100 milli Ampere
  DeviceRemovable    0xc0
  PortPwrCtrlMask    0xa6 
 Hub Port Status:
   Port 1: 0000.0100 power
   Port 2: 0000.0100 power
   Port 3: 0000.0100 power
   Port 4: 0000.0100 power

Bus 003 Device 003: ID 046d:c016 Logitech, Inc. M-UV69a Optical Wheel Mouse
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x046d Logitech, Inc.
  idProduct          0xc016 M-UV69a Optical Wheel Mouse
  bcdDevice            3.40
  iManufacturer           1 Logitech
  iProduct                2 Optical USB Mouse
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           34
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Devices
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      2 Mouse
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      52
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0004  1x 4 bytes
        bInterval              10

Bus 003 Device 001: ID 0000:0000  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         0 Full speed (or root) hub
  bMaxPacketSize0        64
  idVendor           0x0000 
  idProduct          0x0000 
  bcdDevice            2.06
  iManufacturer           3 Linux 2.6.22.9 uhci_hcd
  iProduct                2 UHCI Host Controller
  iSerial                 1 0000:00:1d.2
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0002  1x 2 bytes
        bInterval             255
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             2
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
  bPwrOn2PwrGood        1 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0xc0
  PortPwrCtrlMask    0xa6 
 Hub Port Status:
   Port 1: 0000.0103 power enable connect
   Port 2: 0000.0303 lowspeed power enable connect

Bus 002 Device 001: ID 0000:0000  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         0 Full speed (or root) hub
  bMaxPacketSize0        64
  idVendor           0x0000 
  idProduct          0x0000 
  bcdDevice            2.06
  iManufacturer           3 Linux 2.6.22.9 uhci_hcd
  iProduct                2 UHCI Host Controller
  iSerial                 1 0000:00:1d.1
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0002  1x 2 bytes
        bInterval             255
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             2
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
  bPwrOn2PwrGood        1 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0xc0
  PortPwrCtrlMask    0xa6 
 Hub Port Status:
   Port 1: 0000.0100 power
   Port 2: 0000.0100 power

Bus 001 Device 001: ID 0000:0000  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         0 Full speed (or root) hub
  bMaxPacketSize0        64
  idVendor           0x0000 
  idProduct          0x0000 
  bcdDevice            2.06
  iManufacturer           3 Linux 2.6.22.9 uhci_hcd
  iProduct                2 UHCI Host Controller
  iSerial                 1 0000:00:1d.0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0002  1x 2 bytes
        bInterval             255
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             2
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
  bPwrOn2PwrGood        1 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0xc0
  PortPwrCtrlMask    0xa6 
 Hub Port Status:
   Port 1: 0000.0100 power
   Port 2: 0000.0100 power

#

The HD is found, but none of the neccessary modules are loaded. It looks like 
there is
a) no event generated for this device, or
b) the event generated is lost.
Comment 19 Thomas Schweikle 2007-09-29 08:30:23 EDT
Tested on the same hardware, but with Debian: works as expected! udev 
populates /dev generating events for all connected devices.

On Fedora 7 it does generate events, but it looks as if some of them are 
generated at a point in time, there is no support for them --- they get lost.

Is there a way I can make Fedora populate /dev via udev events only if udev is 
already started and working?
Comment 20 Christopher Brown 2007-09-29 15:18:39 EDT
I'm copying the udev maintainer into this bug as they are best placed to review
this issue. Thanks for attaching the information.
Comment 21 Bruno Wolff III 2007-10-13 14:28:32 EDT
Since I was testing 2.6.20-2936.fc7xen for another problem today, I checked how
my ups was recognized and things worked properly. The Xen kernel is a lot
different, but maybe it will be useful to know that it doesn't have the problem.
Comment 22 Kay Sievers 2007-10-13 14:39:55 EDT
Does running "/sbin/udevtrigger" from the commandline make the nodes appear?
Comment 23 Thomas Schweikle 2007-10-16 06:27:03 EDT
Yes. It exausts various devices and leads to a working, but unmounted usb, 
firewire, or esata atached disk. I have to mount the disk by myself. But: the 
command "/sbin/udevtrigger" has to be given twice to make the devices appear.

The first time the devices are reported, but no device nodes created. Calling 
it the second time the devices are reported and device nodes are created.
Comment 24 Thomas Schweikle 2007-10-16 06:29:58 EDT
Created attachment 228521 [details]
udevtrigger output (/sbin/udevtrigger --verbose)
Comment 25 Bruno Wolff III 2007-10-17 01:45:34 EDT
Things have gotten worse in 2.6.23.1-4.fc7. Now unplugging and replugging my ups
no longer gets it to work. lsusb shows the device, but newhidups doesn't seem to
see it.
Comment 26 Bruno Wolff III 2007-10-30 10:18:03 EDT
2.6.23.1-10.fc7 behaves the same as 2.6.23.1-4.fc7; the UPS isn't recognized
even if I unplug it and replug after a reboot.
Comment 27 Chuck Ebbert 2007-10-30 11:23:36 EDT
Try adding "usbcore.autosuspend=-1" to the kernel boot options.
Comment 28 Bruno Wolff III 2007-10-30 22:54:41 EDT
I tried the following in grub.conf:
kernel /vmlinuz-2.6.23.1-10.fc7 ro root=/dev/md5 usbcore.autosuspend=-1
The behavior was the same as previously for 2.6.23 kernels, nut could not find
the ups. When I switched back to 2.6.22.9-91.fc7 I could unplug and replug the
ups and restart the ups service to get nut to see it.
Comment 29 Bruno Wolff III 2007-11-13 15:54:21 EST
I upgraded to F8 and am now having the problem with 2.6.23.1-49.fc8. Is there
something I should be doing to see if there is really a separate problem causing
my particular UPS (using usb) to not be detected in 2.26.23 kernels as opposed
to not having it detected during the boot process (as was the problem with later
2.6.22 kernels). Since F8 no longer has 2.6.22 kernels it would be nice to even
get back to the case of replugging the device after booting to get it detected.
Comment 30 Bruno Wolff III 2007-11-23 05:42:37 EST
The problem I am having in Fedora 8 is with nut, not the kernel or udev.
I upgraded to 2.6.23.8-62.fc8 and was looking more carefully at what was
happening and finally noticed the error message had changed from what I saw on
Fedora 7. The complaint was about not finding /sbin/nedhidups (which has been
renamed in Fedora 8). When I made a sym link from /sbin/newhidups to
/sbin/usbhid-ups things worked as expected.
I'll stay cc'd to this bug in case you want to ask anything, but don't keep it
open on my account. I'll go file a new bug for nut.
Comment 31 Christopher Brown 2007-12-13 13:48:58 EST

*** This bug has been marked as a duplicate of 249602 ***

Note You need to log in before you can comment on or make changes to this bug.