Bug 253975 - [Indic] - Double cursor showing when Delete by Backspace
[Indic] - Double cursor showing when Delete by Backspace
Status: CLOSED DUPLICATE of bug 288821
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 07:53 EDT by A S Alam
Modified: 2013-07-02 20:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 05:51:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 469552 None None None Never

  None (edit)
Description A S Alam 2007-08-23 07:53:23 EDT
Description of problem:
Double cursor is appearing when try to delete some specific conjuncts (GSUB)
with backspace. Not applicable for all conjuncts. But Its not appearing if those
specific conjuncts places alone ---- Not within any word. Creating problem only
when those appearing within any word and followed by dependent vowels like Vowel
sign AA (U+0B3E)(inscript 'e') and followed by any other GPOS. This is the
observation result so far. 

Version-Release number of selected component (if applicable):
pango-1.17.5-1.fc8
Also present in downgraded version(seen upto pango-1.14.6-2.el5)

How reproducible:
Always

Steps to Reproduce:
1. Open gedit in or_IN locale
2. Enable SCIM with CTRL+SPACE
3. Choose inscript IME
4. Type h=<d"ejs
5. Press left-arrow key once
6. Press Bcakespace once (it will delete 'e' char)
7. Press Backspace once again.
8. Double cursor will appear.
Actual results:
Double cursor showing.

Expected results:
It should not show the double cursor and not deleting properly also.

Additional info:
Screenshot attached.

-- Additional comment from smaitra@redhat.com on 2007-01-08 04:19 EST --
Created an attachment (id=145038)
Screenshot for Double cursor
Comment 2 A S Alam 2007-08-23 07:59:14 EDT
Example for Hindi, 
[(U+0915)+094d+0930+0915+0916] = क्रकख
1. Copy paste in gedit (kedit for correct behavior)
2. goto End  word
3. Move to one word Left
4. Press "Del" key
5. now you can check double cursor
Comment 3 Rahul Bhalerao 2008-03-03 05:47:31 EST
Blinking two cursors is actually a special feature and not a bug. When a
conjunct comes in the middle of a word, and you try to use backspace on it, the
following characters start getting combined due to the exposed 'halant'. This
spoils the entire word and makes the user delete the entire word. To stop such a
behavior for indic scripts, the two blinking cursor feature is implemented, so
that even if the backspace is used on a conjunct between a word, it stops
following characters from forming their conjucts and allows user to correct the
later(erased) part of the conjunct. The current behavior that I see is exactly
how it should be. Thus I think this bug should be closed with a resolution NOTABUG. 


Comment 4 Rahul Bhalerao 2008-03-03 05:51:32 EST
This bug is same as #288821.

*** This bug has been marked as a duplicate of 288821 ***

Note You need to log in before you can comment on or make changes to this bug.