Bug 288821 - [Indic] Backspace key doesn't work correctly - cursors blink in the middle of glyph
[Indic] Backspace key doesn't work correctly - cursors blink in the middle of...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: i18n
: 253975 426776 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 02:26 EDT by A S Alam
Modified: 2013-07-02 20:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 03:30:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2007-09-13 02:26:13 EDT
Description of problem:

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start evolution in bn_IN locale and select New Mail
2. in the "Subject"/"Message Body" widget
3. Select Probhat IM 
4. Type : dir[k/tri 
5. Press left arrow (<-) key one time. 
6. Press backspace 

  
Actual results:
In "Subject" widget, two cursors are blinking, pls see attached screenshot1
In "Message Body" widget, cursor is blinking in the middle of glyph, pls see
attached screenshot2

Expected results:
Cursor should be at one end

Additional info:
it is CLONED bug
Comment 2 A S Alam 2007-09-13 02:42:06 EDT
Package version:
pango-1.18.1-1.fc8
gedit-2.19.91-1.fc8
Comment 4 Liang Zhang 2007-09-28 05:08:21 EDT
The upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=481222
Comment 6 Rahul Bhalerao 2008-01-18 06:44:34 EST
Blinking two cursors is actually a special feature and not a bug. When a
conjunct comes in the middle of a word, and you try to use backspace on it, the
following characters start getting combined due to the exposed 'halant'. This
spoils the entire word and makes the user delete the entire word. To stop such a
behavior for indic scripts, the two blinking cursor feature is implemented, so
that even if the backspace is used on a conjunct between a word, it stops
following characters from forming their conjucts and allows user to correct the
later(erased) part of the conjunct. The current behavior that I see is exactly
how it should be. Thus I think this bug should be closed with a resolution NOTABUG. 
Comment 7 Rahul Bhalerao 2008-03-03 05:51:33 EST
*** Bug 253975 has been marked as a duplicate of this bug. ***
Comment 8 Rahul Bhalerao 2008-03-03 05:59:13 EST
*** Bug 426776 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.